Help with Plasma 5 (Wayland)

I recently installed EOS adding Plasma. However, the login choice is only Plasma(X11) not Plasma(wayland). I have modeset=1 and I believe I have all the essentials for Wayland installed as follows:

local/egl-wayland 2:1.1.9+r3+g582b2d3-1
    EGLStream-based Wayland external platform
local/gtk-layer-shell 0.7.0-2
    Library to create Wayland desktop components using the Layer Shell protocol
local/kwayland 5.93.0-2 (kf5)
    Qt-style Client and Server library wrapper for the Wayland libraries
local/kwayland-integration 5.24.4-1 (plasma)
    Provides integration plugins for various KDE frameworks for the wayland windowing system
local/kwayland-server 5.24.4-1 (plasma)
    Wayland server components built on KDE Frameworks
local/layer-shell-qt 5.24.4-1 (plasma)
    Qt component to allow applications to make use of the Wayland wl-layer-shell protocol
local/libva 2.14.0-1
    Video Acceleration (VA) API for Linux
local/plasma-wayland-protocols 1.6.0-1
    Plasma Specific Protocols for Wayland
local/plasma-wayland-session 5.24.4-2
    Plasma Wayland session
local/qt5-wayland 5.15.3+kde+r44-1 (qt qt5)
    Provides APIs for Wayland
local/sddm 0.19.0-8
    QML based X11 and Wayland display manager
local/swaybg 1.1.1-1
    Wallpaper tool for Wayland compositors
local/wayland 1.20.0-2
    A computer display server protocol
local/wayland-protocols 1.25-1
    Specifications of extended Wayland protocols
local/wayland-utils 1.0.0-2
    Wayland tools to display information about current compositor
local/wlroots 0.15.1-3
    Modular Wayland compositor library
local/xorg-xwayland 22.1.1-1 (xorg)
    run X clients under wayland


inxi -G
  Device-1: NVIDIA TU104BM [GeForce RTX 2070 SUPER Mobile / Max-Q]
    driver: nvidia v: 510.60.02
  Device-2: Lite-On HP Wide Vision HD Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1 driver: X:
    loaded: nvidia unloaded: modesetting gpu: nvidia,nvidia-nvswitch
    resolution: 1: 6880x2880 2: 3840x2160~144Hz 3: 5120x2880~60Hz
    renderer: NVIDIA GeForce RTX 2070 Super with Max-Q Design/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.60.02

Thank you!

It looks like this post should help:

Also appears to have a couple links farther down that may prove useful.

Hope this helps you get it working.

With no wayland, I do not have the option of choosing x11/wayland on the logon screen. I can duplicate your inxi ouput prior to a logout, and after installation there is a dropdown in the lower left for x11/wayland, with the default on x11 (which you see?).

Your output indicates that the 3 items KDE wants to install to use wayland. If you are not seeing the dropdown with the two choices, I would suggest

  • System->UpdateInTerminal from the menu or sudo pacman -Syu from a terminal
  • reboot your machine

If it is still not working come back with results, and anything else you may have tried.


From archwiki

To enable support for Wayland in Plasma, also install the plasma-wayland-session package.

Plasma-wayland-session is already installed. The system is up to date and I have rebooted a few times. The only plasma login item is Plasma(X11). After browsing the forums I’m still stumped.

Am I right that you are running the system on a laptop?
If so, then it could be an Nvidia hybrid issue upstream. Ubuntu had to delay their 22.04 release slightly, because Nvidia hybrid isn’t working on Wayland, so they had to put X11 back in as an option.

Where are you looking?

A laptop, yes, but the GPU is not a hybrid. It uses only the Nvidia card.

1 Like

Bottom right gear icon (gdm login variant, I believe).

Your output above indicates that you have SDDM for a display manager, if you in fact are using GDM then possibly one of these links may help:


1 Like

thanks for the clarification.

Thanks for those links! My Nvidia driver is the current driver 510. As to the same-name problem in the the second post, my Plasma xsession is called plasma.desktop vs. the waylandsessions called plasmawayland.desktop. They aren’t the same.

One additional clue is that the default GNOME desktop is x11. This should be wayland because the xsessions folder has gnome.desktop and gnome-xorg.desktop. Whatever is preventing wayland from showing for plasma is probably also preventing it for GNOME.

1 Like

I found the answer. Now this is assuming all the wayland files are installed. The solution is:

  1. Added these modules to the /etc/mkinitcpio.conf module line: nvidia nvidia_modeset nvidia_uvm nvidia_drm
  2. Update in terminal: sudo mkinitcpio -P
  3. Create a symlink: sudo ln -s /dev/null /etc/udev/rules.d/61-gdm.rules

I now have 2 login entries for each GNOME and Plasma (one for wayland and one for x11)

A caution though: I am having some weird display issues in Plasmawayland after a 3rd reboot, like a missing task/launch panel. Reinstalling plasma-desktop seemed to help.

Thanks for the suggestions here.