Help with /boot/config.txt settings for remote desktop use

I’m trying to set up a persistent remote desktop solution that runs all the time and when you log in to it it is always the same session that remains running even if you log off (so that any running applications aren’t closed on disconnect).

In order to do so I have successfully managed to get EndeavourOS KDE version to auto login on boot. I then successfully connect with x11vnc and get a persistent session, so far so good.

Unfortunately the resolution is extremely low, 800x600 it seems. There is no display according to the plasma display settings page so no way of changing them. This is because there is no physical display and I do not want there to be one, it defeats the purpose of the raspberrys small size to connect monitors and keyboards to it.

In the /boot/config.txt provided by raspbian for RPI4 you can add the following setting to fake a hdmi output:
and then combine that with

to achieve Full HD 1920×1080@60Hz.

However, the /boot/config.txt for Alarm/EndeavourOS looks different and the above settings (which work on raspbian) do not have any effect on my EndeavourOS install.

Does anyone know how to force EndeavourOS to create a “fake” display output with a custom resolution when you autologin and no physical monitor is attached? It is the only only way to get a functioning remote desktop solution that I can think of, although if someone knows a better way I would gladly hear it.

Sounds like a perfect use-case for x2go.

I really tried to get x2go to work but it won’t.

If I use x2go to start a new session there are several problems. Logging in works fine but as you use the system you get many policykit password prompts that should not appear, for things like changing network settings and other things. I suspect there are other policykit related problems because in several of plasmas system settings there was a message saying that settings cannot be saved on this page (but no password prompt). This was among other things the autologin (SDDM) settings page.

The other problem is that while x2go has functionality to return to a previous session, the session seems to be suspended somehow in the meantime which means the system isn’t actually running in the background. For example when I reconnect to my previous session started with x2go my vpn was logged out which in turn stops all torrents (by design).

I have tried to get a working solution on many different distros with many different remote desktop solutions and my conclusion is that there simply is no remote desktop software that can start a fully functioning session that can equal that of a auto login on boot. There is always something wrong, usually related to user rights/permissions.

The second option of trying x2go would be to connect to my existing session that I created though auto login (and not through x2go) and hope that x2gos automatic resolution changing could fix the resolution, unfortunately I can’t connect to that existing session, have tried different things for hours, even installed x2godesktopsharing from the aur which seems to be needed to connect to existing sessions, but no luck, only error messages.

The whole remote desktop situation on all linuxes is a bit of a pain unfortunately.

My last hope it seems is to create an auto login session and force a usable resolution and connect to that but the resolution settings I mentioned above in boot/config.txt dont work on Alarm/EndeavourOS and I was wondering if someone maybe knows a fix for that.

have you see this

I have tried to uncomment only those two lines:

# hdmi_group=1
# hdmi-mode=4

on an default EndeavourOS config.txt, no success. Then after that I have tried all kinds of combinations among other:


hdmi_cvt=2560 1440 60 3 0 0 1

Those last two work on raspberry pi os but not on EndeavourOS unfortunately. At least not for me.