Help please cannot get past lightdm screen when going into i3 environment

I enter my password as usual and then i get kicked off back into the lightdm screen. I did some messing around and figured out that whenever i install and activate picom I cannot login to my i3wm environment but xfce works just fine. I remove picom and I can enter my i3 environment just fine.

Any suggestions?

So you have i3 and xfce installed at the same time?

On separate instances not combined. Mainly in case I ran into this problem to quickly uninstall picom without going into tty. I initially thought it was a bad install so i reinstalled and figured out it was picom causing the loop.

I don’t know what this means.

in lightdm you get the option of choosing which wm to use. I have both xfce and i3.

Read:

Important:

Yes, but this was a problem before I had xfce and only i3. The problem seemed to go away after removing picom and I have no idea why.

alas I’ll give it a try and report back; thank you.

Tried commenting it out. Installed Picom and the login loop still occurs; had to uninstall it again. After commenting out dex starter though I cant seem to choose a different wm now and im in xfce at the moment.

@Elloquin Nvm I retract that statement I am not stuck in xfce but the problem still persists.

Post
inxi -Faz
From terminal.

Why are you doing this?

System:    Kernel: 5.14.2-arch1-2 x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=42e68012-280b-40bc-9bc3-46a896f1a70a rw quiet loglevel=3 
           nowatchdog 
           Desktop: i3 4.19.1 info: i3bar vt: 7 dm: LightDM 1.30.0 Distro: EndeavourOS base: Arch Linux 
Machine:   Type: Laptop System: Apple product: MacBookPro9,2 v: 1.0 serial: <filter> Chassis: type: 10 v: Mac-6F01561E16C75D06 
           serial: <filter> 
           Mobo: Apple model: Mac-6F01561E16C75D06 v: MacBookPro9,2 serial: <filter> UEFI: Apple v: 421.0.0.0.0 
           date: 12/17/2020 
Battery:   ID-1: BAT0 charge: 56.5 Wh (98.3%) condition: 57.5/62.9 Wh (91.4%) volts: 12.5 min: 10.9 model: SMP bq20z451 
           type: Li-ion serial: N/A status: Full cycles: 366 
CPU:       Info: Dual Core model: Intel Core i5-3210M bits: 64 type: MT MCP arch: Ivy Bridge family: 6 model-id: 3A (58) 
           stepping: 9 microcode: 21 cache: L2: 3 MiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19960 
           Speed: 1315 MHz min/max: 1200/3100 MHz Core speeds (MHz): 1: 1315 2: 1247 3: 1197 4: 1435 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds status: Vulnerable: No microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Apple driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:0166 class-ID: 0300 
           Device-2: Apple FaceTime HD Camera type: USB driver: uvcvideo bus-ID: 1-1.1:3 chip-ID: 05ac:8509 class-ID: 0e02 
           serial: <filter> 
           Display: x11 server: X.Org 1.20.13 driver: loaded: intel unloaded: fbdev,modesetting,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1280x800 s-dpi: 96 s-size: 338x211mm (13.3x8.3") s-diag: 398mm (15.7") 
           Monitor-1: LVDS1 res: 1280x800 hz: 60 dpi: 112 size: 290x180mm (11.4x7.1") diag: 341mm (13.4") 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 
           chip-ID: 8086:1e20 class-ID: 0403 
           Sound Server-1: ALSA v: k5.14.2-arch1-2 running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.35 running: no 
Network:   Device-1: Broadcom NetXtreme BCM57765 Gigabit Ethernet PCIe driver: tg3 v: kernel port: efa0 bus-ID: 01:00.0 
           chip-ID: 14e4:16b4 class-ID: 0200 
           IF: enp1s0f0 state: down mac: <filter> 
           Device-2: Broadcom BCM4331 802.11a/b/g/n vendor: Apple AirPort Extreme driver: wl v: kernel modules: bcma 
           port: efa0 bus-ID: 02:00.0 chip-ID: 14e4:4331 class-ID: 0280 
           IF: wlan0 state: up mac: <filter> 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Bluetooth: Device-1: Apple Bluetooth USB Host Controller type: USB driver: btusb v: 0.8 bus-ID: 2-1.8.1.3:9 chip-ID: 05ac:821d 
           class-ID: fe01 
           Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: not found rfk-block: hardware: no software: no 
           address: see --recommends 
Drives:    Local Storage: total: 232.89 GiB used: 12.09 GiB (5.2%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB block-size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 2B6Q scheme: GPT 
Partition: ID-1: / raw-size: 139.07 GiB size: 135.83 GiB (97.67%) used: 11.97 GiB (8.8%) fs: ext4 dev: /dev/sda4 maj-min: 8:4 
           ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%) used: 117.5 MiB (23.5%) fs: vfat dev: /dev/sda3 
           maj-min: 8:3 
Swap:      Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
           ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile 
Sensors:   System Temperatures: cpu: 73.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 198 Uptime: 2h 17m wakeups: 2 Memory: 7.67 GiB used: 1.71 GiB (22.3%) Init: systemd v: 249 
           tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 827 lib: 204 Shell: Bash v: 5.1.8 
           running-in: xfce4-terminal inxi: 3.3.05 
[angel@mbp ~]$ System:    Kernel: 5.14.2-arch1-2 x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=42e68012-280b-40bc-9bc3-46a896f1a70a rw quiet loglevel=3 
           nowatchdog 
           Desktop: i3 4.19.1 info: i3bar vt: 7 dm: LightDM 1.30.0 Distro: EndeavourOS base: Arch Linux 
Machine:   Type: Laptop System: Apple product: MacBookPro9,2 v: 1.0 serial: <filter> Chassis: type: 10 v: Mac-6F01561E16C75D06 
           serial: <filter> 
           Mobo: Apple model: Mac-6F01561E16C75D06 v: MacBookPro9,2 serial: <filter> UEFI: Apple v: 421.0.0.0.0 
           date: 12/17/2020 
Battery:   ID-1: BAT0 charge: 56.5 Wh (98.3%) condition: 57.5/62.9 Wh (91.4%) volts: 12.5 min: 10.9 model: SMP bq20z451 
           type: Li-ion serial: N/A status: Full cycles: 366 
CPU:       Info: Dual Core model: Intel Core i5-3210M bits: 64 type: MT MCP arch: Ivy Bridge family: 6 model-id: 3A (58) 
           stepping: 9 microcode: 21 cache: L2: 3 MiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19960 
           Speed: 1315 MHz min/max: 1200/3100 MHz Core speeds (MHz): 1: 1315 2: 1247 3: 1197 4: 1435 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds status: Vulnerable: No microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Apple driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:0166 class-ID: 0300 
           Device-2: Apple FaceTime HD Camera type: USB driver: uvcvideo bus-ID: 1-1.1:3 chip-ID: 05ac:8509 class-ID: 0e02 
           serial: <filter> 
           Display: x11 server: X.Org 1.20.13 driver: loaded: intel unloaded: fbdev,modesetting,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1280x800 s-dpi: 96 s-size: 338x211mm (13.3x8.3") s-diag: 398mm (15.7") 
           Monitor-1: LVDS1 res: 1280x800 hz: 60 dpi: 112 size: 290x180mm (11.4x7.1") diag: 341mm (13.4") 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 
           chip-ID: 8086:1e20 class-ID: 0403 
           Sound Server-1: ALSA v: k5.14.2-arch1-2 running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.35 running: no 
Network:   Device-1: Broadcom NetXtreme BCM57765 Gigabit Ethernet PCIe driver: tg3 v: kernel port: efa0 bus-ID: 01:00.0 
           chip-ID: 14e4:16b4 class-ID: 0200 
           IF: enp1s0f0 state: down mac: <filter> 
           Device-2: Broadcom BCM4331 802.11a/b/g/n vendor: Apple AirPort Extreme driver: wl v: kernel modules: bcma 
           port: efa0 bus-ID: 02:00.0 chip-ID: 14e4:4331 class-ID: 0280 
           IF: wlan0 state: up mac: <filter> 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
           running-in: xfce4-terminal inxi: 3.3.05 ackages: pacman: 827 lib: 204 Shell: Bash v: 5.1.8 emd v: 249 a3 -min: 8:4  

To fix screen tearing and to allow blur.

This is an apple product?

Yes, it’s a macbook pro.

@Shjim Can you help them?

maybe try LTS…that be 1st move for me

How do I swap kernels on the fly again? Also using refind since im dual booting with macos If that’s a factor. I also think I have installed LTS but not sure.

@Shjim I checked and I have linux-lts-5.10.64-1
how would I swap to it?

@Shjim I figured it out installed AKM but thank you. Hopefully this fixes the problem. :confused: