Help needed writing How To | Replace Pulseaudio with Pipewire for EndeavorOS

This whole thing was so confusing. In my Wine games, half the time the sound would not work. I had to toggle the volume up and down to get Wine to recognize it before the game launched. The other issue, a microphone icon in the task bar (KDE) kept popping on and off, and every time it showed, I had sound issues. Apparently a bug or something, saw reports filed on it.

I decided to revert back to Pulseaudio legacy including Pulseefects, and now everything is back to normal…and more importantly…works correctly.

Yes. pavucontrol still works when using pipewire instead of pulseaudio.



So far from my testing (with Gnome Desktop) I have to use pavucontrol so I can dependably switch my audio inputs and outputs (Bluetooth Headphones, HDMI Audio to TV). Gnome will just clear my preferred choice in Gnome settings.

Additionally pulseeffects is having issues when interacting between desktop applications and Web Applications. Symptoms:

  • The sound,music will change to a slower speed.
  • You will stop music\sound and it will take several seconds to stop.
  • When using Firefox with Web Applications, the Web Application may request a different latency settings which will cause cracking and popping when pulseeffects is running.
  • There is also some configuration issues between the updates where audio is cutting out.

I’ve included some sources as we all navigate through the various issues.>=0.3.23)

1 Like

This is the exact bug, but reverse, I have with Pulse btw. Amusing in a way.

Keep in mind that PipeWire is still early in development, under very active development (77 commits in the past week), and is seeing very regular releases.

There are things that didn’t work last week that do work this week.

Therefore, if you find an unfiled bug then report it to the developers:


:slight_smile: Its like you got a free re-mix of a song you did not know you had. LOL

1 Like

Last update broke my audio. Removing pulse and installing pipewire fixed it for the most part. I still get no audio from Plexamp though, which is a big bummer.

This is a one year old thread.
If you need help with troubleshooting, please create a new thread.