[Help needed] Cannot switch Chinese input method in Google Chrome under Wayland environment

I have a newly installed EndeavourOS with Gnome desktop. I installed Chrome, fcitx5-im, fcitx5-chinese-addons, and fcitx5-material-color using yay. I followed the instructions on https://fcitx-im.org/wiki/Using_Fcitx_5_on_Wayland to configure the environment variables XMODIFIERS=@im=fcitx and QT_IM_MODULES=“wayland;fcitx;ibus”. And added the ~/.config/gtk-4.0/settings.ini and ~/.config/gtk-3.0/settings.ini files. The input method works fine in non-Electron applications, and I can also switch the input method to Chinese in Electron applications under the xwayland environment (but the interface flickers constantly and the input lag is large). I added --enable-features=UseOzonePlatform --ozone-platform=wayland to the Electron application startup command to make it run on Wayland, but I cannot switch the input method. After searching Google, I found that it should be --enable-features=UseOzonePlatform --ozone-platform=wayland --gtk-version=4 for Gnome, but it still doesn’t work for me. I also confirmed that GTK is installed. Is there any other solution? I have a problem with X11 in Idea, so I don’t want to consider it for now.I would be very grateful if anyone could help me solve this issue.