Help Kodi 19 + iptvSimple not working anymore!

Looking for help to solve problem with Kodi 19 + iptvSimple .
Kodi has been working perfect with iptvSimple but after yesterday’s update it now crashes on startup .
Terminal shows this - /usr/bin/kodi: line 208: 3264 Segmentation fault (core dumped) ${KODI_BINARY} $SAVED_ARGS
Crash report available at /home/northernfrog/kodi_crashlog-20210504_230122.log .

Crash log line 208 shows me this - Thread 51 (Thread 0x7f9f68ff9640 (LWP 3323)):
#0 0x00007fa05611337f in poll () from /usr/lib/libc.so.6
#1 0x00007fa057564afc in ?? () from /usr/lib/libavahi-common.so.3
#2 0x00007fa057564681 in avahi_simple_poll_run () from /usr/lib/libavahi-common.so.3
#3 0x00007fa057564859 in avahi_simple_poll_iterate () from /usr/lib/libavahi-common.so.3
#4 0x00007fa057564a8e in avahi_simple_poll_loop () from /usr/lib/libavahi-common.so.3
#5 0x00007fa057564b5b in ?? () from /usr/lib/libavahi-common.so.3
#6 0x00007fa057667299 in start_thread () from /usr/lib/libpthread.so.0
#7 0x00007fa05611e053 in clone () from /usr/lib/libc.so.6

How can I fix this problem , was hoping today’s updates would have fixed it but diden’t happen . What should be my next step ?

One possibility is to revert (downgrade) the offending update. The wiki has information on how. When you see an relevant update, try again. If it works, all is well - if not, then loop (re-downgrade to working version).

Another is to just wait it out - and there may be more choices that I didn’t think of at the moment - apart from filing bug reports with the provider, of course! Might speed up the wait time…

1 Like

Not sure what to downgrade as i don’t recall kodi or iptvSimple being one of the packages that were upgraded . I think it’s maybe the libc.so.6 causing problem . Got me lost , and not wanting to make things worse at this time . I’m surprised no one else having the same problem . I think I’ll wait and see if it fixes itself over next couple weeks . I can live without TV Guide for awhile . I’ll mark as resolved for now and wait … Thank You

@Moonfrog Glad you got ti working. However, I would also post on the issues page of iptvSimple. This way the developer knows the problem you are having. It can be found here:

Also, since this add-on is apart of Kodi’s official repository, they will support any issues with it on their forums. You can find their forum here:

https://forum.kodi.tv/

Just make sure to post the COMPLETE logs with both sites.

3 Likes

Thank You , I looked into it and is being worked on . Only good news is that I’m not alone . Now the waiting game . Hope it dosen’t take to long .
Thanks to All for the help …

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.