Help installing NVIDIA drivers


I re-installed everything from scratch after having failed to use Davinci Resolve on my Alienware laptop:

Could you help me please to install the right NVIDIA drivers? This time I didn’t install Davinci Resolve first, so that I don’t mess with the drivers, it is a clean install of EndeavourOS.

Thank you.

Have you had a look at the Wiki articles on NVIDIA:

After reading the NVIDIA intro, you might want to have a look at

1 Like

Is it the same hardware you had before? You already installed the nvidia drivers once. It’s the same procedure if it’s the same hardware?

yay -S nvidia-470xx-dkms
yay -S nvidia-470xx-settings
1 Like

Ok, thank you. I wanted to be sure as this time I didn’t install Davinci first (when installing Davinci, I had to install drivers during the install), will try again this evening…

Thanks for the links.

1 Like

What was the issue with davinci-resolve? Thought you had it working?

I can import videos, but I have this pop up first, then the video isn’t editable and hardly playable (stops after a few seconds). And Davinci doesn’t recognize my cuda installation (I could have chosen cuda in Davinci settings to try solving this error -59).


Well I don’t know not having used davinci resolve and also you have older gpu so I’m not sure. Would take some time trying to figure it out. Something you’ll have to contend with.

I am back home, I just installed however at the end of the installation of

yay -S nvidia-470xx-dkms

I have this:

==> dkms install --no-depmod nvidia/470.182.03 -k 6.4.1-arch1-1
Error! Bad return status for module build on kernel: 6.4.1-arch1-1 (x86_64)
Consult /var/lib/dkms/nvidia/470.182.03/build/make.log for more information.
==> WARNING: `dkms install --no-depmod nvidia/470.182.03 -k 6.4.1-arch1-1' exited 10

Should I care about it?

Hum, that is weird. When I re-installed EndeavourOS (to have a fresh install), I had the above error message when installing yay -S nvidia-470xx-dkms

On installing EndeavourOS I chose btrfs and grub, because I wanted to install Timeshift and have snapshots in the grub.

I just did a new EndeavourOS install (I am tired now :slight_smile: ) but this time I chose ext4 and didn’t choose grub and now I could install yay -S nvidia-470xx-dkms

Could choosing btrfs and grub prevent to install successfully nvidia-470xx-dkms?

I don’t think so. I’m not sure what is happening. I use btrfs with grub and I install btrfs-assistant, snapper-support and btrfsmaintenance. This gives you everything you need. The 470xx drivers are an AUR package and should install no problem. I’m not sure what you are doing? After installing the Nvidia drivers you would have to restart. If you’ve already used ext4 you can use timeshift also. I’ve been using btrfs-assistant from the beginning and I have no issues.

Edit: The only difference is I have an Nvidia GTX 1060 on one machine running with Wayland that has Intel. On the other it is a Ryzen with AMD graphics. Both machines are running grub with btrfs and I can log in under Wayland or X11.

Both are on KDE Plasma.

I’m not that experienced with package build issues. So i really can’t say what this means. Maybe @manuel could explain? :thinking:

Contents of that file would be interesting to see.


I am still trying to install

yay -S nvidia-470xx-dkms

I reinstalled EndeavourOS with btrfs and grub and tried again.

I have the same error

(2/2) Install DKMS modules
==> dkms install --no-depmod nvidia/470.182.03 -k 6.4.1-arch2-1
Error! Bad return status for module build on kernel: 6.4.1-arch2-1 (x86_64)
Consult /var/lib/dkms/nvidia/470.182.03/build/make.log for more information.
==> WARNING: `dkms install --no-depmod nvidia/470.182.03 -k 6.4.1-arch2-1' exited 10

but this time I kept the logs:

There seems to be a problem with the maintenance of this AUR package.

They recommend a kernel patch that should help, see

As I’m not using this package, I don’t know if the patch helps or not.

1 Like

I had the same problem today, but I solved it:
I’ve just followed the instructions that you can find here:

In addition I reinstalled with yay -S lib32-nvidia-470xx-utils the package to run wine applications

1 Like

Thank you. I just followed your link and successfully installed. However I have a question. As a newbie, how things will be manageable when there will be an official update? Will I have to uninstall/re-install something?

Thank you.

That depends on the package maintainer, who may add the patch to the PKGBUILD. If the patch gets added, then a normal yay command should build the update.

Anyway, it is good to follow the discussion at
and maybe even contribute to the discussion if needed.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.