Help finding more glphys/unicode

Where would I be able to find more of these unicode icons?

I suppose by default i3wm edition comes pre installed with Font Awesome. You can see their cheat sheet down below

In case you use one of the Nerd Fonts, their cheat sheet is here

I personally use Nerd Fonts, because it has much more icons - including that of Font Awesome and other popular icon packs.

@flyingcakes Thank you. I’m kinda new at this: would it be as simple as copying and pasting the glyph into the i3config or is there another step?

1 Like

You can simply copy paste the icons.

ive tried that with a discord icon ive seen from the first link and upon pasting it into a text editor it just says Github

Are you sure you copied the icon only and not the following text?
Seems to work for me

@flyingcakes Do you have a pro plan because I don’t quite have the same layout of icons that you do unless i’m using the site wrong

You seem to be on the version 6 beta page.

Simply click on the link I shared. It sends you to version 5 page. Scroll down and you’ll see all icons.

Discord is under the “Brands” tab.

And no, I don’t have their subscription. The link I shared sends you to their free icons cheat sheet.

@flyingcakes Using just the v5 version of the site and searching the brands I found discord thank you; but I’m 100 percent copying and pasting the icon and upon pasting it in the text editor I get


I really don’t know what i’m doing wrong

You could try installing the font awesome package I am using

sudo pacman -S ttf-font-awesome

And then force updating font cache. (not required, but just to be very sure)

sudo fc-cache -frv

I tried with Xed, I can paste icons.

Tried the commands the problem still persists; is there somewhere I have to manually change the font to maybe in the config file? I thought by default awesome was used in i3wm endeavourOS because I see it in the config file.

Sorry to bother you with this btw; this seems to be way more complicated than It needs to for me for some reason.

Your config looks perfectly fine
You can see icons on the top bar that confirm.

In your terminal, open file ~/.config/i3/i3blocks.conf. Scroll down and check if your terminal can display icons that are there in that file.

No, It still shows Github lol what in the world is happening

If you can wait, I’ll do a clean VM install this evening and check.

Of course I can wait but you don’t have to go through all that effort for me. I even tried using brave browser and still get the same issue. I really appreciate you trying to help me thus far though.

1 Like

Ah no problem. I’m spinning up a VM or two almost everyday. Its a 10-15 minute job for me to do a clean install and try.

Even I am curious - why is it not working :face_with_monocle: :thinking:

If this helps these work perfect https://fontawesome.com/v4.7/cheatsheet/

Ok thats strange. I remember switching to version 5 1 because the older version didn’t work.

1. And then eventually to Nerd Fonts

Do you think my fonts are outdated somehow?

@flyingcakes I am using LTS if that is a factor to it somehow