Help diagnosing hard lockup during CPU intensive operations

Hello! New EndeavourOS user here…

I’m having a hard lockup issue that I had coming from Ubuntu 22.04.

The lockup occurs during extended gaming, but more frequently when trying to compile something. I’ve tried to narrow it down, and I think its hardware related. First thing I did was check the BIOS settings, and the second thing I did was run Memtest86+. I identified some RAM that was bad, and removed it, and ran Memtest86+ overnight (6 passes) which resulted in 0 errors. Problem kept happening, and I adjusted a couple more BIOS and motherboard settings, which have not helped.

I’ve booted into a LiveUSB and installed Phoronix Test Suite, and ran a CPU test which results in the lockup occuring after about a couple minutes of 100% CPU. Using btop++ I’ve seen CPU temp as high as 97C, which to me is pretty high, but I’m not sure if that’s the cause, as when I’m gaming, the temp never gets much over 80C, unless there is a spike that does not show up.

I have tried LTS Kernel with no change in behavior.

Magic sysrq is on, works, but not during freeze.

If left alone system will reboot itself.

Not to sure where to go from here. Please let me know if there is anything else required.


journalctl -b -0

inxi --full --verbosity=7 --filter --no-host

System: Kernel: 6.0.1-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0 Desktop: KDE Plasma v: 5.26.0 tk: Qt v: 5.15.6 wm: kwin_x11 vt: 1 dm: SDDM Distro: EndeavourOS base: Arch Linux Machine: Type: Desktop Mobo: ASUSTeK model: P8Z68-V v: Rev 1.xx serial: <superuser required> UEFI: American Megatrends v: 3603 date: 11/09/2012 Battery: Message: No system battery data found. Is one present? Memory: RAM: total: 7.73 GiB used: 2.12 GiB (27.4%) RAM Report: permissions: Unable to run dmidecode. Root privileges required. CPU: Info: quad core model: Intel Core i7-2600K bits: 64 type: MT MCP smt: enabled arch: Sandy Bridge rev: 7 cache: L1: 256 KiB L2: 1024 KiB L3: 8 MiB Speed (MHz): avg: 2154 high: 5900 min/max: 1600/5900 cores: 1: 5900 2: 1648 3: 1600 4: 1690 5: 1600 6: 1600 7: 1600 8: 1600 bogomips: 56040 Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts clflush cmov constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept est flexpriority flush_l1d fpu fxsr ht ibpb ibrs ida lahf_lm lm mca mce md_clear mmx monitor msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pebs pge pln pni popcnt pse pse36 pti pts rdtscp rep_good sep ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_deadline_timer vme vmx vnmi vpid xsave xsaveopt xtopology xtpr Graphics: Device-1: AMD Tahiti XT [Radeon HD 7970/8970 OEM / R9 280X] vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-1 pcie: speed: 5 GT/s lanes: 16 ports: active: DP-1,DP-3 empty: DP-2, DP-4, DVI-D-1, DVI-I-1 bus-ID: 01:00.0 chip-ID: 1002:6798 class-ID: 0300 temp: 45.0 C Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1 Screen-1: 0 s-res: 4000x2560 s-dpi: 96 s-size: 1058x677mm (41.65x26.65") s-diag: 1256mm (49.45") Monitor-1: DP-1 mapped: DisplayPort-0 pos: primary,top-left model: Gigabyte M27Q serial: <filter> res: 1440x2560 dpi: 109 size: 335x596mm (13.19x23.46") diag: 801mm (31.5") modes: max: 2560x1440 min: 640x480 Monitor-2: DP-3 mapped: DisplayPort-2 pos: primary,bottom-r model: Gigabyte M32Q serial: <filter> res: 2560x1440 hz: 165 dpi: 93 size: 698x393mm (27.48x15.47") diag: 801mm (31.5") modes: max: 2560x1440 min: 720x400 OpenGL: renderer: AMD Radeon HD 7900 Series (tahiti LLVM 16.0.0 DRM 3.48 6.0.1-zen2-1-zen) v: 4.6 Mesa 22.3.0-devel (git-8721323100) direct render: Yes Audio: Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20 class-ID: 0403 Device-2: AMD Tahiti HDMI Audio [Radeon HD 7870 XT / 7950/7970] vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie: speed: 5 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 1002:aaa0 class-ID: 0403 Sound API: ALSA v: k6.0.1-zen2-1-zen running: yes Sound Server-1: PulseAudio v: 16.1 running: no Sound Server-2: PipeWire v: 0.3.59 running: yes Network: Device-1: Intel 82579V Gigabit Network vendor: ASUSTeK P8P67 Deluxe driver: e1000e v: kernel port: f040 bus-ID: 00:19.0 chip-ID: 8086:1503 class-ID: 0200 IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> IP v6: <filter> type: noprefixroute scope: link WAN IP: <filter> Bluetooth: Device-1: ASUSTek Bluetooth Adapter type: USB driver: btusb v: 0.8 bus-ID: 2-1.7:5 chip-ID: 0b05:179c class-ID: e001 Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled rfk-block: hardware: no software: no address: see --recommends Logical: Message: No logical block device data found. RAID: Message: No RAID data found. Drives: Local Storage: total: 3.87 TiB used: 151.66 GiB (3.8%) ID-1: /dev/sda vendor: Western Digital model: WDS250G1B0A-00H9H0 size: 232.89 GiB speed: 6.0 Gb/s type: SSD serial: <filter> rev: 10WD scheme: GPT ID-2: /dev/sdb vendor: Western Digital model: WD40EZAZ-19SF3B0 size: 3.64 TiB speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 0A80 scheme: GPT Optical-1: /dev/sr0 vendor: HL-DT-ST model: BD-RE BH20N rev: C105 dev-links: cdrom Features: speed: 40 multisession: yes audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: running Partition: ID-1: / size: 227.88 GiB used: 33.35 GiB (14.6%) fs: ext4 dev: /dev/sda2 label: N/A uuid: a834b639-ab1f-4283-bcb2-8d00eca49a84 ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1 label: N/A uuid: 2536-8DD1 ID-3: /home size: 3.58 TiB used: 118.31 GiB (3.2%) fs: ext4 dev: /dev/sdb1 label: 4TB uuid: 0c0e6ccc-83f7-43b4-a248-97ef82053e50 ID-4: /mnt/8TB size: 7.22 TiB used: 3.24 TiB (44.9%) fs: nfs4 remote: ID-5: /mnt/ServerDownloads size: 121.99 GiB used: 45.58 GiB (37.4%) fs: nfs4 remote: Swap: ID-1: swap-1 type: file size: 12 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile Unmounted: Message: No unmounted partitions found. USB: Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900 Hub-3: 2-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0 speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900 Device-1: 2-1.3:3 info: Logitech G5 Laser Mouse type: Mouse,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 98mA chip-ID: 046d:c041 class-ID: 0300 Hub-5: 2-1.4:4 info: Logitech G11/G15 Keyboard / USB Hub ports: 4 rev: 1.1 speed: 12 Mb/s power: 100mA chip-ID: 046d:c223 class-ID: 0900 Device-1: 2-1.4.1:6 info: Logitech G11/G15 Keyboard / type: Keyboard,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 1.5 Mb/s power: 100mA chip-ID: 046d:c221 class-ID: 0300 Device-2: 2-1.4.4:7 info: Logitech G15 Keyboard / LCD type: HID driver: lg-g15,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 046d:c222 class-ID: 0300 Device-3: 2-1.7:5 info: ASUSTek Bluetooth Adapter type: Bluetooth driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 100mA chip-ID: 0b05:179c class-ID: e001 Hub-6: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0 speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 Hub-7: 4-0:1 info: Super-speed hub ports: 2 rev: 3.0 speed: 5 Gb/s chip-ID: 1d6b:0003 class-ID: 0900 Sensors: System Temperatures: cpu: 42.0 C mobo: N/A gpu: amdgpu temp: 45.0 C Fan Speeds (RPM): N/A Info: Processes: 215 Uptime: 3h 12m wakeups: 0 Init: systemd v: 251 default: graphical Compilers: gcc: 12.2.0 clang: 16.0.0 Packages: pm: pacman pkgs: 1288 Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.22

This is not okay, especially on a desktop PC.

Ok! I was planning on a Cooler Master 212 EVO 2 anyway… I’ll go pick one up today and install and update.

Thanks for the reply!

Temp is too high! @ 97C

Edit: This would be normal

System Temperatures: cpu: 42.0 C


The Tcase temperature of the Intel® Core™ i7-2700K is 72.6°C. It means the maximum temperature over the processor. Processor is capable to support up to 90 Celsius degrees for small periods of time.

Make sure you use fresh thermal paste, of a known good brand, as well as make sure you apply it right, as that alone may already be the issue :hot_face:, not the cooler :cold_face: you have.

1 Like

Installed a new cooler, with new thermal paste, and temps at idle are ~35C. Old cooler thermal paste was old and hard. Suspect that was the issue.

I will load test another day and report back if problems persist.

Thanks you very much for the assistance!

1 Like

That’s why I use the good albeit more expensive stuff. After decades of messing with computer hardware you learn some things. :smirk:

1 Like


Loaded CPU to 100% for about 30 mins and temps got as high as 58C. New cooler works very well. Thank you for all the input. Should have caught this one myself.

[Solution] Replace thermal paste on old hardware or purchase upgraded CPU cooler.

Also: Always apply new thermal paste after removing or replacing the cooler, as it has to be squished :melting_face: down to fill any gaps. Trying to reuse the old past can, and very likely will cause trouble, and can get very expensive if your processor burns out. :hot_face:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.