Help compiling XanMod

so, a few months back I heard about the xanmod kernel, I’ve only been installing prebuilt binaries of the kernel until yesterday where I decided to compile it through the aur package, but I used yay instead of cloning the repo manually, but doing that now I realised that inside the PKGBUILD file in the xanmod package there’s a microarchitecture flag which defaults to 0 (generic) and just above the flag, with a comment, it says that for it to be intel native the flag needs to be 98, and well having used yay I have absolutely no idea whether the build process used my CFLAGS or set the microarchitecture flag automatically, can anyone help me figure this out

You just need to set the _microarchitecture variable in the terminal before you run the build command in the same terminal.

You could either set it in your .bashrc resp. .zshrc, like

export _microarchitecture=98

or you can do a one time off with

env _microarchitecture=98 yay -S linux-xanmod

oh, right, I didn’t think of that, thanks lol

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.