Hello all, newbie coming from PopOS!

I saw in the documentation something about optimus, but I never worked with it. I will take a look into it. thank you.

but yeah. AMD is a safe bet for my next buy.

really. since this is only a welcome post. I am overwhelmed about the nice welcoming and this community. really looking forward for my EOS journey. :slight_smile:

1 Like

thank you. yes. I think I will take the leap of faith and will dive into EOS.

I will keep you updated. :smiley:

but first I have to backup my current system. ^^

thank you. yessss. indeed those are good recommendations since it really helps if such things are in place when experimenting. :slight_smile:

thank you. I do not care really about hybrid graphics but I will look into. thank you.

and yeah. some wise man told me that breaking things is the only way to learn. :wink:

For what it’s worth, from what I recall, PopOS does not support on the fly switching. Rather, it provides a menu option to pick the GPU for the next login.

I think you are right from my recollection also. :thinking:

hmm. they do have a hybrid mode. but to be honest I never went into detail here.

games went by using the dedicated graphics driver but I do not know which unit was used in idle mode.

source: https://support.system76.com/articles/graphics-switch-pop

START HERE FOR NVIDIA USERS WITH HYBRID GRAPHICS, ie INTEL/NVIDIA: Note this is relevant for Optimus users like myself who have an Intel Integrated graphics chip as well as an Nvidia MX150 graphics card for my laptop. To my knowledge this is only supported for Xorg, I can’t say the same for Wayland in it’s current developmental state.

Source: https://discovery.endeavouros.com/nvidia/nvidia-optional-enhancements-and-troubleshooting/2021/03/

You’ll want to force nvidia-drm.modeset=1, by adding it to the grub.cfg so to do that:

sudo nano /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="nvidia-drm.modeset=1 quiet loglevel=3 nowatchdog"

Make it look like that, save the file, ctrl+x, hit Y to save. Then rebuild the grub.cfg

sudo grub-mkconfig -o /boot/grub/grub.cfg

Next part to this, is force nvidia drivers to load on early boot (helps to prevent black screens before login screen)

sudo nano /etc/mkinitcpio.conf

# vim:set ft=sh
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)
MODULES="nvidia nvidia_modeset nvidia_uvm nvidia_drm"

save the file, ctrl+x, hit Y to save and rebuild the mkinitcpio.conf

sudo mkinitcpio -P

Reboot and should be good to go!

For a bonus (you don’t have to do this if you don’t need to), in case you want to avoid screen tearing:

sudo nano /etc/X11/xorg.conf.d/20-nvidia.conf

Section "Device"
    Identifier "Nvidia Card"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    Option "NoLogo" "true"

Section "Screen"
        Identifier      "nvidia"
        Option         "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
        Option          "TripleBuffer"                  "on"
        Option          "AllowIndirectGLXProtocol"      "off"

save the file, ctrl+x, hit Y to save

Use a hook to make sure you do get kernel images to rebuild on updates:

sudo pacman -S nvidia-hook

**Final note, this was source mainly from the amazing EndeavourOS wiki, I just had it written all down in LibreOffice in case I ever needed to do a fresh install, I could be up and running quickly, instead of having to search all over the place again for solutions to problems I already fixed once, Good luck! :stuck_out_tongue:

Edit: I’ll also add this just in case it may also help. With optimus you can either have the intel graphics (no thanks!) or use the dedicated Nvidia graphics (yes please!). To get that to work, we have to do a bit more work, but it’s straightforward and simple enough!

Sourced from the following:

yay -S optimus-manager

yay -S optimus-manager-qt

Reboot your system

Check optimus manager service (should be running)

systemctl status optimus-manager

If it’s not running, start and enable it:

sudo systemctl enable --now optimus-manager

Now open and use optimus-manager app to select from tray icon>settings>optimus tab> startup mode: NVIDIA and now whenever you start your system, it should default to always Nvidia ON. You can select other options from that list if you would prefer something also.

I’d also recommend using the LTS kernel :wink:

sudo pacman -S linux-lts
sudo pacman -S linux-lts-headers

@Scotty_Trees that is exactly why I want to use the open source driver.

the step provided above are just cumbersome to say at least, and if something fails its pretty difficult to figure out why. If I would need to run the nvidia proprietary then I would just install the driver and disable intel.

Note for me, anything that has more than 3-4 steps is cumbersome​:grin:

It actually is only 3-4 steps when you simplify it down:

  1. Edit Grub & update it
  2. Prevent possible Screen tearing
  3. Install optimus manager
  4. Reboot

Yeah but you know what I mean. Each time I try something is wonky on a case by case, just wish I had a AMD gpu at this point.

Edit: on pop os you can just click to switch the gpu…

1 Like

PopOS is the most streamlined for Nvidia users out of all the distros I’ve tested, so they deserve my gratitude and respect for their development there. If anyone ever needs an Nvidia setup that literally just works after install, PopOS is the place to be.

But EndeavourOS doesn’t do what PopOS does because part of the ethos of EndeavourOS is it leaves it all up to the user what they do or don’t want to install or tweak in regards to Nvidia. It’s simply two different approaches. If EndeavourOS wanted to do what PopOS does with Nvidia, I’m sure that wouldn’t be an easy workload for the devs to update and maintain and honestly running a handful of terminal commands to get my Nvidia system working the way I expect it to is really a piece of cake and I’m an Arch newbie! :stuck_out_tongue:

1 Like

For sure, just making sure that the OP has the right expectation. EOS is great but quite different, I prefer much more this approach where I can build and tweak my system. But what concerns nvidia it is also key to know what you are doing because many just copy past in the terminal and expect the hybrid graphics to work. It doesnt always as intended from my experience.

Plus one to that!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.