Hello again! Cannot download anything date dor upue to keying error ("Unknown Trust")

That was fast.
So I cannot do yay or sudo pacman -Syu because "signature from ‘[name] ’ is unknown trust. The file that it downloads is corrupt “(invalid or corrupted package (PGP signature)).”
I’ve tried just about everything listed on the forums and have had little luck. Again, any help would be appreciated.

Here are a couple of things to try:

  1. refresh your mirrorlist and update again

  2. If 1 didn’t work, run first: sudo pacman -Sy archlinux-keyring endevouros-keyring and then update

1 Like

Already tried that

That was number 2 on the list.

Number 1 ?

…I already tried that.
I should add that due to the keyring funny, I cannot update period.

So please give all the info in your OP or in one and same post so we know what we are dealing with. Thank you!


does eos-update --aur do the same ?

Yes. Although I haven’t seen that one yet

I think so. If I am not mistaken, it should take care of the keyring’s issue.

I don’t have it installed so I cannot verify.

1 Like

If refreshing the mirrorlists and installing the keyrings didn’t work:

there is always the wiki :grimacing:


lol that never ever (ever) happend to me :sweat_smile:

1 Like

Just to be clear, your 13th install, did you choose to do it with the offline version of the installer ?