Heads up: Kernel 6.1-rc# might break backlight control on old/weird laptops


If you’re lazy and don’t want to click on the link…
Red Hat developer Hans De Goede was recently refactoring the backlight detection code for kernel 6.1, and noticed that some laptops may lose the ability to control their backlight as a result. If you are using a laptop, it is recommended that you check the output of the following command:

ls /sys/class/backlight/

If it shows only one entry such as “intel_backlight”, “nouveau_bl”, “amdgpu_bl0” or “radeon_bl0” then your laptop might be affected - as such it is recommended to adding this parameter to the kernel command line: [HOW TO ADD KERNEL PARAMETERS]


after which you should check /sys/class/backlight/ again. If an “acpi_video0” entry appears in the ls output, then you’re in the clear. If not, you have a laptop which is likely affected by the upcoming change.

If so, run the following commands:

    ls /sys/class/backlight > ls-backlight.txt

    sudo dmesg > dmesg.txt

    sudo dmidecode > dmidecode.txt

    sudo acpidump -o acpidump.txt

And send an email about this at hdegoede@redhat.com with the 4 generated .txt files attached.



I’m using a Thinkpad E14 Gen4 AMD. Gnome backlight shortcuts doesn’t works with the latest 6.1.1 kernel. No problem with 6.0.12 before updating kernel. Confirmed after a downgrade to 6.0.12 which works perfect. Same behavior with Zen kernel.

But according to Hans’ instruction I’m on the “clear” side :

  • only amdgpu_bl0 without kernel parameter
  • acpi_video0 is present after adding acpi_backlight=0 to the kernel

Any suggestion ? I’m thinking about send a mail to Hans with my 4 generated .txt files but I’m not sure that is the correct path to solve that.


I’m currently having the same issue, on GNOME I can’t adjust the brightness on my laptop. Only happens on 6.1.1, was fine on 6.0.12 and it’s currently working fine on 5.15.85 LTS

Have you tried acpi_backlight=vendor on the Lenovo?

Edit: Fixed typo

Just wanted to report that adding acpi_backlight=vendor as a Kernel parameter did fix the backlight issue on my end. My laptop model is an Acer Swift X SFX14-41G if anyone is having the same problem. Thank you very much!


Thank you for you suggestion.

I tried, but my problem is not solved. With acpi_backlight=vendor Gnome shortcuts have strange behavior : no change to the backlight (which seems to be set at max value), and shortcut to increase brightness is blocked.

I tried with acpi_osi=linux added to acpi_backlight=vendor but no change.

You are updating grub after adding these to the default command line?

I’m using systemd-boot since Cassini fresh install. AFAIK there is no need to do more than editing the entry conf file. But maybe I misunderstanding something ?

Okay …yes systemd. This is going to be hard for me having another setup to deal with that i don’t know as well. I’m not sure how this works with systemd-boot? :thinking:


:eye: https://wiki.archlinux.org/title/Kernel_parameters#systemd-boot

So it’s like editing the grub file but no updating required?

Yes, exactly.

Some news…

For my case (Thinkpad E14 with AMD GPU), brightness control is finally working fine with acpi_backlight=native to the 6.1 kernel.

Problem solved for me.

1 Like