Headphones Recognized But Sound Goes To Laptop Speakers

If I open sound settings in the toolbar or open Pulse, the headphones show connected when plugged in and not connected when not plugged in. In either case, sound goes to the laptop speakers. I am on Cinnamon with all updates current. Below is my inxi -Fxxxz --no-host. Jack works fine in Windows, and has worked with no issues in other distros. I know it isn’t purely an EOS/Cinnamon issue since my headphone jack works as expected on a nearly identically setup computer just with different hardware. Any help would be greatly appreciated.

System:
  Kernel: 5.10.7-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.0 
  Desktop: Cinnamon 4.8.5 tk: GTK 3.24.24 dm: LightDM 1.30.0 
  Distro: EndeavourOS 
Machine:
  Type: Laptop System: Alienware product: Alienware 17 R3 v: 1.8.0 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: Alienware model: 02VCTC v: A00 serial: <filter> UEFI: Alienware 
  v: 1.8.0 date: 05/30/2019 
Battery:
  ID-1: BAT1 charge: 86.2 Wh condition: 86.2/96.5 Wh (89%) volts: 16.5/14.4 
  model: COMPAL PABAS0241231 type: Li-ion serial: <filter> status: Full 
  Device-1: hidpp_battery_0 model: Logitech M510 serial: <filter> 
  charge: 55% (should be ignored) rechargeable: yes status: Discharging 
CPU:
  Info: Quad Core model: Intel Core i7-6700HQ bits: 64 type: MT MCP 
  arch: Skylake-S rev: 3 L2 cache: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 41621 
  Speed: 2800 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 2800 2: 2800 
  3: 2800 4: 2799 5: 2802 6: 2801 7: 2800 8: 2801 
Graphics:
  Device-1: Intel HD Graphics 530 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:191b 
  Device-2: NVIDIA GM206 [GeForce GTX 960] vendor: Dell driver: nvidia 
  v: 460.32.03 bus ID: 02:00.0 chip ID: 10de:1401 
  Device-3: Sunplus Innovation Integrated_Webcam_HD type: USB 
  driver: uvcvideo bus ID: 1-7:8 chip ID: 1bcf:2b8c 
  Display: x11 server: X.Org 1.20.10 driver: intel,nvidia 
  unloaded: fbdev,modesetting,vesa alternate: nouveau,nv resolution: 
  1: 1920x1080 2: 1920x1080~60Hz 3: 1920x1080~60Hz 4: 1920x1080~60Hz 
  s-dpi: 96 
  OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 20.3.3 
  direct render: Yes 
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a170 
  Device-2: NVIDIA GM206 High Definition Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus ID: 02:00.1 chip ID: 10de:0fba 
  Device-3: Apple USB-C to 3.5mm Headphone Jack Adapter type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 3-1:2 chip ID: 05ac:110a 
  serial: <filter> 
  Sound Server: ALSA v: k5.10.7-arch1-1 
Network:
  Device-1: Qualcomm Atheros Killer E2400 Gigabit Ethernet driver: alx 
  v: kernel port: d000 bus ID: 3c:00.0 chip ID: 1969:e0a1 
  IF: enp60s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel port: d000 
  bus ID: 3d:00.0 chip ID: 8086:24f3 
  IF: wlan0 state: up mac: <filter> 
Drives:
  Local Storage: total: 1.14 TiB used: 292.78 GiB (25.0%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: PM951 NVMe 256GB 
  size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: BXV77D0Q 
  temp: 25.9 C 
  ID-2: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630 
  size: 931.51 GiB speed: 6.0 Gb/s serial: <filter> rev: A3P0 
Partition:
  ID-1: / size: 55 GiB used: 19.26 GiB (35.0%) fs: btrfs dev: /dev/nvme0n1p5 
  ID-2: /boot/efi size: 96 MiB used: 34.1 MiB (35.5%) fs: vfat 
  dev: /dev/nvme0n1p2 
  ID-3: /home size: 610 GiB used: 273.48 GiB (44.8%) fs: btrfs 
  dev: /dev/sda4 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 55.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 281 Uptime: 11m wakeups: 3 Memory: 31.22 GiB 
  used: 2.18 GiB (7.0%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  clang: 11.0.1 Packages: 1348 pacman: 1345 snap: 3 Shell: Bash v: 5.1.4 
  running in: gnome-terminal inxi: 3.2.01

Moderation Edit Fixed output formatting.

Which one are your headphones connected to?

1 Like

Sorry, the jack that fails is the Intel one. The USC-C to 3.5mm adapter is my current workaround to at least get something working.

1 Like

The first thing i would try is to use pavucontrol on configuration tab disable all other devices and enable the headphone only, if this is not working you can try paprefs and enable simultaneous output:

3 Likes

I will give these ideas a shot later today. Thanks!

Tried both with no change. Despite showing headphones when plugged in and speakers when not, the sound still comes from the laptop speakers alone no matter the configuration.

what does alsamixer from terminal shows you?

Which option? Available sound cards are HDA Intel PCM, NDA NVidia and USB-C to 3.5mm Headphone Jack Adapter.

Likely this one:

1 Like

Changed it in alsamixer with no impact. Even with sound settings reflecting the headphone state, playback goes to laptop speakers when Intel is selected. At least it works right with the usb-c>3.55mm adapter selected. Thanks for trying to help.

1 Like