Headphone jack not working


First time using Endeavour OS. Previously, everything was functioning correctly, but now both the front and back headphone jacks are not working (does not show device). However, the USB and HDMI connections still provide audio output. Interestingly, the headphone jack starts working again after a core update (reboot prompt show up) and stops working upon rebooting

Does anyone have any insights into what might be causing this problem?

I’m using XFCE on a custom maching (B450 tomahuk max ii)

Welcome to the forum, @dire001 :enos:

For anyone to help you out, you’d have to provide more info.


It could be a failing cable, or, or …pipewire-jack not installed, or pipewire alltogether not installed properly, or, or…


the headphone is working properly. i tested it on other device
Pipewire-jack is installed. i tried to reinstall it but it not help.
is there anything i can do to get more troubleshoot information?

You could start sharing more info on your hard- and software, like I suggested above.

inxi -Fxxc0z | eos-sendlog and post the output-URL here.


here is the output

Thanks. There seems to be an awful lot of similar cases:


Is pipewire-pulse installed?

most of the result are windows relate or work around. it not help

pipewire-pulse is installed

and as i mentioned . it work after a core update (when the reboot recommend prompt show up) and stop working after reboot

To find a potential culprit, you’d have to view your pacman.log. It lives in /var/log/pacman.log.

cat /var/log/pacman.log
…will show you the complete log-file.

Try to find the update, you are referring to, and paste only those lines here, using the symbol of “</>” in your post-editor.

Else, to show some boot-logs (which may, or may not help out in this case), and viewing them without appending | eos-sendlog:

Last boot -
journalctl -b -0 | eos-sendlog

Second-last boot -
journalctl -b -1 | eos-sendlog

Third-last boot -
journalctl -b -2 | eos-sendlog

sorry, i did not phase it correctly.
i meant every times the system install a core update, the headphone jack work again until reboot.
it work after those line apear:

( 1/13) Reloading device manager configuration...
( 2/13) Arming ConditionNeedsUpdate...
( 3/13) Updating module dependencies...
( 4/13) Install DKMS modules
==> dkms install --no-depmod broadcom-wl/ -k 6.3.5-arch1-1
==> depmod 6.3.5-arch1-1
( 5/13) Running kernel-install...
:: Running kernel-install for kernel 6.3.5-arch1-1

I tried to reload the device manager configuration but not work

1 Like

This is a normal thing, as the newer, updated kernel modules (DKMS) are being installed and then loaded again…

Mind, such an update is only really “finished”, after you reboot your computer. :wink:

If indeed the sound is not working after a reboot (and only before a reboot, after a DKMS rebuild), there must be something wrong with your kernel / driver installation, me thinks.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.