HDMI port not shown in xrandr (no external display works)

Hi everyone,

I just got a fresh installation of the OS one week ago and everything was working fine, especially I had aside from my laptop’s display an additional external display. I had the external display connected once via HDMI and once via USB-C.

However, since one occasion the external display is not recognized anymore, independent of how I connect it to the laptop. On that occasion what happened was:

  1. I had the laptop connected to the display (and it was working)
  2. Put the laptop to standby
  3. Disconnected the display
  4. Wanted to use the laptop so opened the lid to resume from standby
  5. OS crashed

Since then, neither in gnome settings nor xrandr the display or the HDMI port shows up. For example, this is what xrandr shows:

[felix@felix ~]$ xrandr -q
Screen 0: minimum 16 x 16, current 3840 x 2400, maximum 32767 x 32767
eDP-1 connected primary 3840x2400+0+0 (normal left inverted right x axis y axis) 340mm x 210mm
   3840x2400     59.96*+
   2048x1536     59.95  
   1920x1440     59.97  
[... many more possible resolutions are shown here ...]

I would be really glad for any help. I have absolutely no idea where to start - tried a few things from other forums, but they all seem to effectively have different issues.


Welcome to the community Felix.
If you have a HDMI to DP adapter etc. maybe you can try that and connect to the DP? I had similar issues at one time, basically a loose slot in the GPU. Would not work at times. If your display takes a basic VGA, I would try that as well.

Hi, yea I tried that already, also tried using my USB docking station / replicator - none of these ports (USB C, HDMI, DP or those via the USB C replicator works). It seems to be a software-based issue. Note that using the same machine, when I run windows it works just fine.

I have this as well. Just installed a few days ago on my laptop, and xrandr only reports the internal display, despite the HDMI cable being connected and the display seeing something

I’m using Plasma-Wayland, and this is the first time testing an external display.

Here’s my xrandr output as well

HaydenLaptop% xrandr
Screen 0: minimum 16 x 16, current 1920 x 1080, maximum 32767 x 32767
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
   1920x1080    119.93*+
   1440x1080    119.92  
   1400x1050    119.90  
[and a lot more resolutions]

I also had this same problem on Manjaro after really screwing around with my video drivers (because thanks Nvidia), then I made the switch to Endeavour.