"HDMI Disconnected" - but it's not! xrandr/second monitor woes

I just installed EndeavourOS on a HP All-in-One (aio) pc. It has a 12th gen Intel chip with onboard graphics. It has 1 HDMI port on the back, as well as 1 DisplayPort. Installation was…normal? I’ve installed EOS a few times over the years and it was uneventful - the only weird thing was when I clicked “install” (after selecting all the options, like, language, partitions, etc), it went back to the boot-type selection screen and went unresponsive until the installation was complete. I don’t think that’s related, but who knows.

I did on online install, and verified that everything was up-to-date. I installed i3 (my DE of choice) as well as XFCE, Cinnamon, and Gnome, because I like to stay in touch with them. I performed the following steps on ALL of those DEs.

So I plugged in an external monitor which works with another computer, using the same HDMI cord. The AIO screen went black, the way it usually does when you plug in a new monitor, and the second monitor also went black. Then the AIO screen went back to how it had been before, and the second monitor showed a “HDMI NO INPUT” message. xrandr showed the AIO monitor and all of its modes, and listed FOUR displayports and 4 HDMI ports - HDMI1, HDMI2, etc, all marked as “HDMI DISCONNECTED”.

I googled for a bit but didn’t find many threads/suggestions that seemed relevant. The things I tried were:

  1. updated the BIOS (which updated successfully/uneventfully) and
  2. to provide HDMI1 with a mode, then turn it off and on again (HDMI1 via xrandr I mean, not the computer itself. I restarted the computer multiple times.).

(I’m at home now; this occurred at work; so I don’t have the exact commands, but it was something like these)

xrandr --output HDMI1 --mode 1920x1080
and then
xrandr --output HDMI1 --off
xrandr --output HDMI1 --auto

After that, HDMI1 showed the new mode (until reboot, after which it disappeared), but still showed as “disconnected”. (FWIW, arandr just shows one monitor.)

Hardware wise, I tried the following:

  1. Tried a different HDMI cable
  2. Added my KVM switch between the monitor and the AIO pc - I don’t know why I tried this, it didn’t seem like it would do anything, but I was at the point of trying everything!

I did not try a displayport connection - I didn’t have a DP cable handy - I hope to find one at home and try that tomorrow.

Anyone have any thoughts/suggestions?

some hardware info would be interesting :wink:


xrandr --output HDMI-1 --mode 1920x1080 --pos 0x0 --rotate normal

that dash was missing, why off?
or use
it helps you to find the proper settings ( yay -S arandr)
ctrl + Return to apply
Save as e.g. monitor.sh
chmod +x monitor.sh
Edit: can be HDMI1 (arandr shows what are the actual ports)

1 Like

yes the go to tool if you use EndeavourOS i3 setup… use arandr and save the setup as monitor and the config will read this on login:

Thanks everyone for the responses. I’m back at work so troubleshooting should be easier.

Before I go through some of the suggestion replies, here are the syslogs:


can be HDMI1 (arandr shows what are the actual ports)

Yes, xrandr shows it as HDMI1, though when I look at it in the /sys/class/drm folder, it shows them as


I don’t really know what that means (it was just some question someone else asked in some thread somewhere), but I figured I’d mention it.

arandr was installed by default and I did open it - but it only shows the main display, and all other outputs (in the outputs menu at the top) are grayed out.

Ok so I tried a DisplayPort cable and it works. So… I still have no idea why HDMI didn’t work - but the problem is solved.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.