Having to manually run dunst in terminal to get notifications

I’ve recently installed i3wm and I’m currently learning how to configure it. I’ve ran into an issue where my screenshot utility, Flameshot, crashes once I take a screen shot. After some reading I’ve discovered that this has to do with dunst.

From Flameshot troubleshooting FAQ:

Most tiling window managers do not come with a notification daemon, and Flameshot communicates with the user through notifications. This means that Flameshot is dependent on a notification manager to be installed and running. Easy way to test if you have a notification manager is to try notify-send "test" in your terminal. If you see the notification, you have it, otherwise we suggest you to install a notification manager such as dunst:

Naturally I’ve got dunst installed as I ran the endeavour i3 install scripts (manually, not through calamares) so that my i3 config file has exec_always --no-startup-id dbus-launch dunst --config ~/.config/dunst/dunstrc in it.

However I’ve noticed that dunst doesn’t seem to work unless I manually run ‘dunst’ in the command line. If I run notify-send test it doesn’t come up before I run dunst in another terminal.

Is this an issue that other people are having as well? And does anyone know of a solution or how to find a solution?

Thanks in advance!

boring info

OS: EndeavourOS Linux x86_64
Shell: bash 5.1.16
CPU: 11th gen Intel i3-115G4 (4) @ 4.1000GHz
GPU: Intel Tiger Lake-LP GT2 [UHD Graphics G4]

Relevant dotfiles: https://github.com/runarcn/dotfiles/tree/main/i3

default fresh install i3 EndeavourOS… dunst running fine…
same for flameshot:
must be something on your setup. You may have another notificator running and they fight each other?

1 Like

I found out what the issue was!

Apparently, dunst wasn’t running at all on my system even though I had exec --no-startup-id dbus-launch dunst --config ~/.config/dunst/dunstrc in my i3 config file, so I just added exec dunst to it and now it works. It’s still not optimal since the notifications are displayed at the bottom of the screen while I have my bar at the top and since I don’t have a ‘click to disable notifications option’ (yet) but it works!

Damn, I love the feeling of figuring something out.

Thanks Joe<3 might not have been the concrete solution, but it made me find out what the issue was<3

man, I love this forum

move it then !

it in dunstrc

    # Position the notification in the top right corner
    origin = bottom-right

    # Offset from the origin
    offset = 30x40


Why do you invoke dbus-launch at all?
According to arch wiki all you need is running /usr/bin/dunst.

This part shouild be redundant as well.

Just for a reference this is my startup for dunst.

exec_always --no-startup-id "killall dunst; sleep 1; /usr/bin/dunst"

that’s just from the default endeavouros config, haven’t written that myself

it could be an issue calling it with dbus-launch in cases… i do not have issue in test installs in VM and also not on some real installs… butr may dunst changed and do not need this anymore …

--config ~/.config/dunst/dunstrc is only there to show how you may add a second config if you want to try out something could go to comments instead i think…

I vaguely remember that there may be problem with calling just dunst. But using full path /usr/bin/dunst should work without problem. Or maybe I confuse it with some other program.

i do stop using dunst… and try out mate-notifications currently… they are clickable

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.