Having Issues while updating packages

Plz some one guide me to solve this issue… need help i tried many thing but it didn’t worked

1 Like

It looks like you didnt have updated the endeavouros-keyring.

Take a look in that post it is clearly described what to do.

1 Like

not worked

is your pacman.conf up to date?

i think someone else needs to look over it. maybe @pebcak is around

1 Like

that’s what the problem is while updating my pacman it shows this problem

well i don,t know may things can u guide me how to do it

Try this “quick & dirty” fix:

sudo pacman-key --recv-keys 0F20FADC599D1C46EB556455AED8858E4B9813F1

sudo pacman-key --finger 0F20FADC599D1C46EB556455AED8858E4B9813F1

sudo pacman-key --lsign 0F20FADC599D1C46EB556455AED8858E4B9813F1

Then run:

sudo pacman -Sy endeavouros-keyring
sudo pacman -Su
1 Like

if you need a new pacman.conf take this one

# /etc/pacman.conf
# See the pacman.conf(5) manpage for option and repository directives

# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg     = pacman glibc
#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
ParallelDownloads = 5

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

SigLevel = PackageRequired
Include = /etc/pacman.d/endeavouros-mirrorlist

#Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

#Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

#Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

1 Like

sir what should i do here

Yes/ NO

Sir after choosing Yes and running cmd sudo pacman -Su the issue is still there

I m confused …

must be a typo.
try sudo pacman -Syu

take a look if you have you updated your pacman.conf

Looks importing the key manually and signing it locally didn’t work either.

You could answer NO there.

“Nuclear Option” :wink:

sudo pacman -Sc

sudo mv /etc/pacman.d/gnupg /etc/pacman.d/pacman-key.bak

sudo pacman-key --init

sudo pacman-key --populate archlinux endeavouros

sudo pacman -Syy archlinux-keyring endeavouros-keyring

sudo pacman -Su

Thanks sir but nothing changed its same .The problem is still occuring

should i have to choose NO on that option

pity I would have liked to help but I am out

1 Like


Please post terminal output as text and not screenshots.

Copy, paste, highlight and press Ctrl-E to format for better readability.




Sorry sir my mistake

1 Like

sudo pacman -S archlinux-keyring
afterwards, update.

Thanks a lot Sir Finally the problem got solved !!!


now its have been updated so do i still have to run that cmd sudo pacman -S archlinux-keyring