Having Graphic Bugs after Hibernation

Hey,

today I wanted to test Endeavouros, with Gnome, but I noticed that after my first restart Hibernation started to cause graphic bugs. After a fresh install of Endeavouros hibernation works only until I Reboot the system.

The graphic bugs where very different, sometime I could only see artifacts sometime my screen just turned green with some other weird behavior.

This Problem was only fixable by rebooting. After a reboot the System worked normally, until I used hibernation again.

My Systemlogs and Systemspecs

I only encountered this problem with Endeavouros. Manjaro and Fedora don’t have these problems.

My guess is that I have memory problems, but its weird that it only happens with Endeavouros.

Hope someone can help me.

could be you are using GNOME wayland session? if so try login via Xorg session.
And make sure DRM modeset is enabled on boot.
And welcome here at the forum.

I do see also Bios/Firmware is from 2015?

  Mobo: ASUSTeK model: Z97-A v: Rev 1.xx serial: <superuser required>
    UEFI: American Megatrends v: 2601 date: 08/18/2015
1 Like

You mean that you didn’t have to configure anything to have hibernation?

I picked the option with the swap file, otherwise it just worked.

Using a Xorg Session worked, but why can’t I use Wayland? I mean Fedora works fine with Wayland or do I need to setup something for it?

Oh, right! I always forgot about that option because that’s available only if you wipe everything, which I never do.

do you have DRM Modesetting enabled for Nvidia in Grub?

nvidia-drm.modeset
Force nvidia-drm.modeset=1:

adding nvidia-drm.modeset=1 to the kernel parameter inside grub:

sudo nano /etc/default/grub

and put nvidia-drm.modeset=1 inside (leave the rest untouched!!) as you can see here:

# GRUB boot loader configuration

GRUB_DEFAULT=0 GRUB_TIMEOUT=5

GRUB_DISTRIBUTOR="EndeavourOS"

GRUB_CMDLINE_LINUX_DEFAULT="nvidia-drm.modeset=1 resume=UUID=...

save the file [Ctrl+X] and rebuild the grub.cfg:

sudo grub-mkconfig -o /boot/grub/grub.cfg

Yes it is already enabled.