Having a problem with dual boot

Just installed endeavouros alongside zorin os and can’t seem to boot into endeavouros

a few more info would be needed to help you. where is your bootloader and which one does your system use.

I’m guessing your bootloader is on zorin and it’s grub, if so update grub if not. if you have already updated it, as mentioned earlier, more info.

if using grub, did you activate os-prober ?

Updated grub but there’s nothing unless l use f12 but l want it to be an option on the grub menu


You could try chroot from Zorin, and troubleshoot, or install bootloader.

Edit /etc/default/grub and change the line to:


If it is commented, uncomment it.

Regenerate the Grub configuration file. I believe on Zorin OS running sudo update-grub is enough (the normal command would be sudo grub-mkconfig -o /boot/grub/grub.cfg).

but you do have installed EndeavourOS with grub? or the default systemd-boot ?

1 Like

@Ita running on zorinOS I would prefer to reinstall grub first and than update it.
before that make sure os-prober is enabled (see reply #6)

commands are :

sudo grub-install

sudo update-grub


I opened the grub doc ddnt see that option

Let me try and see


oh, if it is systemd-boot, there is nothing to do with grub…
and you won’t see any EOS in the grubmenu

So should I install grub in endeavouros or

as I understand your first posting, you installed EOS, but you could not use it. right ?
so I would submit to remove and reinstall EOS. - pay attention when installing for choosing the bootloader to grub

It’s okay will just keep on pressing f12 and select endeavouros just ddnt like that but ooh well it’s the only solution l came up with

But then this is out of topic but want to ask that why is when l install a new app l have restart in order to use it?

EOS can find and launch others while Zorin seems can’t recognize EOS and launch it.
Put EOS to the first start position in bios and use it’s grub.
You can see in grub.cfg that EOS requires two images to be started (row:
“initrd /boot/intel-ucode.img /boot/initramfs-linux.img”)
while in Zorin’s grub.cfg is only one image in such place.

sorry, don’t know if and how it is possible to delete systemd-boot and replace it by grub – never used systemd-boot