Have openbox with nvidia - xorg issues heres a fix

Hi I new here to the forum but been using endeveros for a bit now. I have a lenovo legion with Nvidia graphics. I was have severe trouble with screen tearing. Every time I have read and worked out that solution it wouldn’t work. I used the nvidia-settings tool to create the conf file and renamed it and placed it in /etc/X11/xorg.conf.d/20-nvidia.conf reboot and I can barely see my menu couldn’t read the words as it was so small. Everything else was fine just the tearing continued and I just removed everything. Still had a problem with tearing. However every time it would do the same thing then and Idea hit me I remember having to put xrandr in my autostart file a with another computer. so I took the basic setting and placed it in my autostart for my Open box.
here is the command i use at the top of the autostart file

nvidia-settings --assign CurrentMetaMode=“DP-4: nvidia-auto-select +0+0 {ForceCompositionPipeline=On}, HDMI-0: nvidia-auto-select +1920+0 {ForceCompositionPipeline=On}”

this works flawlessly. no other config files to look up and see what settings something may be. So if your having screen tear issues try putting the command above in your autostart file for openbox ofcourse you will need to adjust for your particular system. Hope this helps someone

1 Like

Welcome to the EndeavourOS forum. I hope you enjoy your time here.

Thank you for the information.


1 Like