Hashes do not match with the latest ISO

I have downloaded the latest ISO twice, I did a checksum and I am getting the exact same hashes with the two ISOs.

https://github.com/endeavouros-team/ISO/releases/download/1-EndeavourOS-ISO-releases-archive/endeavouros-2020.09.20-x86_64.iso.sha512

According to this link it shows the sha512 hashsum and it has this value

fa1911a9b80dc148f80d0f38cf027193f3402abc98277be162b7d8708408abb9de6637e70bccbe91666d2208329fad581f59c9020590686e75a094ea13943541

But the hash output I am getting is this:

161D5844DA7BC05FB3FE8AA7F77197133E8E1976B1C65487E808223FDDF438F0223B208B966BE47B74E40C0D9270404402E0C197B8B2E882D4A4D7E432ABD065

I have tried two different programs and they both produce the same hash output.

There was a bugfix yesterday(?) inside the iso. Maybe they didn’t update the hash inside the link.

3 Likes

I downloaded the two ISOs, the first ISO was a few days back. and I just downloaded the same build and both of these ISO’s hashes matches each other

I just checked and the iso and sum work, if taken from here:

1 Like

You got the sum from over here

image

?

Yep

Yeah that is where I got the checksum from and it doesn’t match with the ISO.

I just tried it and it is correct.

3 Likes

Same here. :man_shrugging:

2 Likes

Just tried it myself, sha512sum matches.

So, one or more of the following is probably true:

  1. OP downloaded a wrong file,
  2. there was an error in downloading,
  3. OP does not know how to properly calculate sha512sum

Try to download both endeavouros-2020.09.20-x86_64.iso and endeavouros-2020.09.20-x86_64.iso.sha512 again. Then run the following in the terminal (in the directory where you saved the two files):

diff <(sha512sum endeavouros-2020.09.20-x86_64.iso) endeavouros-2020.09.20-x86_64.iso.sha512

If there is no output, then everything checks out.

2 Likes

The only answer to thisalways re-download the iso and if you can from different mirrorsthere is and will be no other solution.

2 Likes

I am using both the Windows built in version and some third party software and they both produce the same hash.

I downloaded the ISO from github.

Both on Windows and on the third party software I selected the sha512sum

Oh maybe I am not doing that method then. What I did was I selected the file and generated a hash and then I compared it to the file. it shoed different but yeah I will try this method.

I got this:

I am litereally running the exact same command. Completely different.

I do not know what the problem is. Sorry! ISO should be okay. Download it again!

Mine was torrented:

sha512sum endeavouros-2020.09.20-x86_64.iso
fa1911a9b80dc148f80d0f38cf027193f3402abc98277be162b7d8708408abb9de6637e70bccbe91666d2208329fad581f59c9020590686e75a094ea13943541  endeavouros-2020.09.20-x86_64.iso

No problems here.

1 Like

You’re running it on the wrong ISO file. Look at the date in the filename!

The latest ISO file is this:
endeavouros-2020.09.20-x86_64.iso

You have this:
endeavouros-2020.09.19-x86_64.iso

So the problem is point 1 on my list above. :wink:

7 Likes

It’s not fun to solve it so easily! :smiley:

1 Like

Oh strange, for some reason yesterday I was getting the older version when I clicked on the github link. I guess the github link was not updated, today I am getting the latest ISO :slight_smile:

Just curious what was the bug with the previous ISO?