Hardware volume controls not working

I have a Dell Latitude E7440 and for some reason my hardware volume controls stopped working. Have tried searching for this but all has to do with audio card etc. Not sure if this is a Xfce or Arch issue.

I’m afraid I don’t know a lot about these issues, but if anecdotal information is useful, I am running XCFE 4.14 on Arch, EndeavourOS and ArcoLinux - and the controls on the keyboard work for me. I have PulseAudio on them all, if that affects things…

Good luck


yeah I’ve gone through Pulse audio to see if there is setting that got triggered but haven’t seen anything in there that would deactivate my volume controls on my laptop.

Was there a kernel update before that happened?
If yes, did you try booting with an older kernel (lts)?

Never tried that. I guess it’s a good time to start

Hello @Emerald_Archer
Are you getting no sound output?

I am getting sound. And can control the levels through Pulse. On my laptop I have physical volume buttons that for some reasons are not working anymore that is my current issue.

Oh…i see the buttons are actually not functioning. :upside_down_face:

I figured it ok. When I installed Plank I removed everything but Whiskers menu on the lower panel. So because the hardware button wasn’t working I added Pulse audio plug in back and for some reason I tested the button again and it started to work. Why this is a thing I don’t know but I 'm glad its working again.