Hardware acceleration in chromium

I am using endeavourOS with wayland and I want to enabled hardware acceleration in chromium. After using some flags and enabling vaapi, chrome://gpu shows that it is enabled but chrome://media-internals show that vpxvideodecoder is used. I have hardware accelerated codecs in my gpu. It is an intel jasperlake 32 eus.

Checked by vainfo and intel-media-driver, hardware encoding and decoding is enabled.

Can someone help. Vaapi is enabled with flags but it is not being used. I cannot use firefox it is very inefficient. It causes high cpu usage on arch based distros.

Why use anything chromium? chromium is shit!
I would never use any thing running chromium.

And soon thy gonna kill almost all functionality of ad-blockers in ALL chromium based shit.

Any form of Firefox is that way to go! And no issue with hardware acceleration on Firefox.

1 Like

Because I use a chromium based browser called brave. It does have inbuilt adblock and it is great to use. Firefox has hwaccel but it causes my laptop to have like 150/400 CPU usage and heavy battery drain.

I just put this here in case you have not come across it:

https://wiki.archlinux.org/title/Chromium#Hardware_video_acceleration

1 Like

Already tried.It shows that GPU acceleration is enabled in chrome://GPU but it is not. Checked by Intel GPU top.

Please find something else.

Could you print sudo lspci -v?
So what’s the output of vainfo? (I know you said you checked…) and cat ~/.config/chromium-flags.conf?

Alright …

Here: https://bbs.archlinux.org/viewtopic.php?id=244031

:slightly_smiling_face:

5 Likes

I have never seen it working. Also don’t look for chromium but for your specific browser, those things are highly dependent on the actual vendor and even package.

Short answer for Brave: No.

Are you sure that the Intel GPU top is reading things correctly? Have you done a reboot since setting it?

Someone offered help because they do not know what you have already tried because you failed to tell us of all what you have tried in the OP. Please remember people here volunteer their time and expertise to help others. The more information you give us about what you have already tried will expedite getting your issue solved sooner and it will keep people from suggesting things you already tried.

3 Likes

I’ve no idea for brave (not using it as I don’t trust them regarding their history, but that’s me hey) but it does indeed work (on my system) with ungoogled-chromium

1 Like

I’ve no idea for brave (not using it as I don’t trust them regarding their history, but that’s me hey) but it does indeed work (on my system) with ungoogled-chromium

Now I have seen it all. :wink:

But can’t confirm, nothing triggers va-api here.

I’m not sure I understand?

@linuxislife

How do you bring up that media tab?

I am not seeing it here:

Click on the 3 vertical dots, then go to more tools, you will find it there

2 Likes

Great! Thanks!

Have you tried updating your BIOS? lol

On a more serious note, I can confirm it works. For me it works on brave, google chrome, chromium, you name it. Even on wayland. The secret ingredient is making sure that you have

--enable-features=VaapiVideoDecodeLinuxGL
1 Like

I’m using Firefox with va-api, but I’m trying to keep an eye on what other browser support. In the past I was not able to get hardware accelerated video decoding going in anything other than FF.

When it comes to chromium I haven’t found a particular package, myriads of flag-combinations etc. that provide any hardware acceleration - no matter what about:gpu claims.

The latest news I’m aware of is:

Just checked ungoogled-chromium and chrome-dev: Doesn’t work here.

So, it’s a YOU problem, no matter what you can or can not confirm.

1 Like

I just followed the wiki. I’ve noticed there are a lot of “exeptions” pointed out there, though.

that’s my # lspci -v https://0x0.st/H7Nd.txt

vainfo
$ vainfo
Trying display: wayland
Trying display: x11
vainfo: VA-API version: 1.20 (libva 2.20.1)
vainfo: Driver version: Intel iHD driver for Intel(R) Gen Graphics - 24.1.3 ()
vainfo: Supported profile and entrypoints
      VAProfileNone                   :	VAEntrypointVideoProc
      VAProfileNone                   :	VAEntrypointStats
      VAProfileMPEG2Simple            :	VAEntrypointVLD
      VAProfileMPEG2Simple            :	VAEntrypointEncSlice
      VAProfileMPEG2Main              :	VAEntrypointVLD
      VAProfileMPEG2Main              :	VAEntrypointEncSlice
      VAProfileH264Main               :	VAEntrypointVLD
      VAProfileH264Main               :	VAEntrypointEncSlice
      VAProfileH264Main               :	VAEntrypointFEI
      VAProfileH264Main               :	VAEntrypointEncSliceLP
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileH264High               :	VAEntrypointEncSlice
      VAProfileH264High               :	VAEntrypointFEI
      VAProfileH264High               :	VAEntrypointEncSliceLP
      VAProfileVC1Simple              :	VAEntrypointVLD
      VAProfileVC1Main                :	VAEntrypointVLD
      VAProfileVC1Advanced            :	VAEntrypointVLD
      VAProfileJPEGBaseline           :	VAEntrypointVLD
      VAProfileJPEGBaseline           :	VAEntrypointEncPicture
      VAProfileH264ConstrainedBaseline:	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline:	VAEntrypointFEI
      VAProfileH264ConstrainedBaseline:	VAEntrypointEncSliceLP
      VAProfileVP8Version0_3          :	VAEntrypointVLD
      VAProfileVP8Version0_3          :	VAEntrypointEncSlice
      VAProfileHEVCMain               :	VAEntrypointVLD
      VAProfileHEVCMain               :	VAEntrypointEncSlice
      VAProfileHEVCMain               :	VAEntrypointFEI
      VAProfileHEVCMain10             :	VAEntrypointVLD
      VAProfileHEVCMain10             :	VAEntrypointEncSlice
      VAProfileVP9Profile0            :	VAEntrypointVLD
      VAProfileVP9Profile2            :	VAEntrypointVLD

flags looks like:

$ cat ~/.config/chromium-flags.conf
--enable-gpu-rasterization
--enable-features=VaapiVideoDecodeLinuxGL
1 Like

Nope. Firefox’s RDD process is hitting the GPU, chromium does nothing.

Well, how else is it supposed to work? I’m not God inhabiting billions of other consciousnesses. :wink: