Hang on restart

Installed Mate and on restart it hangs for over 2 minutes. A stop job is running for user manager UUID 1000

[rick@mate-pc ~]$ systemd-analyze blame
Bootup is not yet finished (org.freedesktop.systemd1.Manager.FinishTimestampMonotonic=0).
Please try again later.
Hint: Use 'systemctl list-jobs' to see active jobs
[rick@mate-pc ~]$ 
[rick@mate-pc ~]$ systemctl list-jobs
JOB UNIT                           TYPE  STATE  
 78 man-db.timer                   start waiting
 68 shadow.timer                   start waiting
  1 graphical.target               start waiting
  8 time-sync.target               start waiting
 83 updatedb.timer                 start waiting
 95 pamac-cleancache.timer         start waiting
 67 timers.target                  start waiting
  5 systemd-time-wait-sync.service start running
  2 multi-user.target              start waiting
 70 logrotate.timer                start waiting

10 jobs listed.
[rick@mate-pc ~]$ 

I set timedatectl-local-rtc 1 so NTP is active and restart is not hanging as before. Anything else with the above timers i need to worry about?

how was the system time itself ?

I set it this way because time is out due to dual booting with Windows 10. I just wondered why it’s hanging on shutdown because no other desktop has done this. It was taking 2 minutes saying stop job is running for user manager UUID 1000 but since i set the time to local and made sure NTP was active it is not now. So i guess it’s not that it’s hanging it’s just waiting. Now it say’s wpa supplicant stopping on restart but it doesn’t take long. Just wondered about all these timers?

check systemctl -l systemd-time-wait-sync.service

one job hold the other …

[rick@mate-pc ~]$ systemctl -l systemd-time-wait-sync.service
Unknown operation systemd-time-wait-sync.service.
[rick@mate-pc ~]$

sorry, ehhhhh is old year :stuck_out_tongue: systelctl status -l systemd-time-wait-sync.service

[rick@mate-pc ~]$ systemctl status -l systemd-time-wait-sync.service
● systemd-time-wait-sync.service - Wait Until Kernel Time Synchronized
     Loaded: loaded (/usr/lib/systemd/system/systemd-time-wait-sync.service; enabled; vendor preset: disabled)
     Active: activating (start) since Tue 2019-12-31 13:33:00 EST; 44min ago
       Docs: man:systemd-time-wait-sync.service(8)
   Main PID: 373 (systemd-time-wa)
      Tasks: 1 (limit: 38441)
     Memory: 1.0M
     CGroup: /system.slice/systemd-time-wait-sync.service
             └─373 /usr/lib/systemd/systemd-time-wait-sync

Dec 31 13:33:00 mate-pc systemd-time-wait-sync[373]: adjtime state 5 status 40 time Tue 2019-12-31 18:33:00.110874 UTC
Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.
[rick@mate-pc ~]$ 

i got it on disable in my system

cannot advice specifik :slight_smile:

Well i leave it for now this way as it isn’t hanging for 2 minutes on restart now.

disable that thing :slight_smile: it communicate with the kernel about time i guess with the system…

i tell you a secret , my bios time is different then the system time lol, one side is bad but if i change it , it gona do something again … i let it stay because system now is good only in bios

I can try it i guess. What do i use to stop it? systemctl stop or disable systemd-time-wait-sync.service?

stop is for a session , disable you switch it off

1 Like

Not resolved after all as it came back. Even tried disabling systemd-time-wait-sync.service. :confounded: Moving to something else for now!

I also got this error “Bootup is not yet finished” when i ran systemd-analyze in my windows dual boot with Budgie desktop everytime i cold start the system . I changed windows 10 to use local time, after that this error disappeared.

Yes, I normally I set local time otherwise every time booting between Windows and Linux the time will be out for me about 4 hours. Unfortunately the issue of restarting is still happening where it has a this job running for use manager UUID 1000 and takes 2 minutes to initiate the restart. Haven’t figured that one out yet. :disappointed:

systemctl disable systemd-time-wait-sync && systemctl stop systemd-time-wait-sync
or use welcome app and click on Detect system Issues :
Bildschirmfoto_2020-01-04_23-54-46

1 Like

Yes, I have seen this come up now and have used it on a few different desktops. I’m finding though that it seems to be running afterwords again. If you run the button at a later time it still comes up yet i don’t see it do anything running it because the first time it does disable it. Not sure if it’s starting backup? It has done this on a few different desktops.

Edit: The only desktop I have had a problem hanging on the restart was mate though.