GTX 1080 Ti horrible performance, drivers issue?

I’m having huge issue with my new fresh install and hope to find some help here.
I did install EndeavourOS today (with the Nvidia option) and faced few bugs like application flashing from time to time, global and video performance absolutely terrible. I have the feeling that I have some issue with my GPU driver or something related to it but I can’t solve it.
For the context, I’m new to Linux clients.

So here is the issue:

  • Everything look like if it was running in 1080 instead of 4k
  • Everything video related is laggy
  • I tried few games to test if everything run smooth but it wasn’t the case, except Phasmophobia that had absolutely zero issue (Proton 9.0-1).
  • Tried Helldivers 2 (Proton 9.0-1): it run but it look very bad compared to Windows 10 and it’s so laggy that is unplayable
  • Terraforming Mars (Proton 9.0-1): The game works but it’s flashing from time to time with Wayland, doesn’t seem to do it with DX11
  • Tried Scythe Digital Edition (Proton 9.0-1, then 6.3-8 after reading if I launch the game with regular option it just never start (registered as platinum on protondb), if I launch it in OpenGL it gave me this error:

OPENGL ERROR: failed to choose pixel format for dc 410039
GLContext warn: failed to setup offscreen pixel format: Success.
GLContext: failed to create context: Success.
GLContext: failed to register master context class: Success.
Failed to initialize graphics.
Make sure you have DirectX 11 installed, have up to date
drivers for your graphics card and have not disabled
3D acceleration in display settings.
InitializeEngineGraphics failed

So here is what I did to troubleshoot:

  • Made some research on Google and on this forum about issue regarding my GPU
  • Read the Linux Gaming Guide from the forum
  • Verified all the pre-requisites about package etc. The only thing I don’t have installed is the lib32 package since everything is in 64bits from my config, I suppose
  • Verified the xorgs logs (didn’t see any relevant stuff)
  • Verified that I have the last driver
  • Verified that my GPU support Vulkan
  • Reinstalled the Nvidia driver with Pacman
  • Tested a X11 session instead Wayland

I also saw this topic about issue with Nvidia 550 drivers but I don’t know if it’s relevant and how to downgrade correctly the driver. The last answer is using an AUR package but I don’t know if it’s the best practise way?

Here is my configuration:
Intel i7 6800k
Asus Sabertooth x99
Corsair Vengeance LPX 2133Mhz - 64Go (8x8)
Asus GeForce GTX 1080 Ti ROG STRIX OC 11 Go

Nvidia Driver 550.78

Thanks for reading me :slight_smile:

PS: English is not my native language

Is it possible to post the hardware output? Post the url

inxi -Faz | eos-sendlog

Hi, here is the log requested!

Hardware looks okay. Post #32 shows how the user downgraded here.

I have a similar system that is working okay but I’m not gaming. So it could be the Nvidia drivers or the platform you are running on. (Proton)

I don’t think Proton could be the only cause since I have flashing outside of Steam and video look like caped to HD in YouTube for example.

The post 32 is these commands right?

pacman -R nvidia-dkms nvidia-settings nvidia-utils
yay -S nvidia-535xx-dkms nvidia-535xx-utils nvidia-535xx-settings

I did try the first line yesterday and none of these packages was installed so I wasn’t sure that I was using dkms at all and if it was applicable because the topic was talking about laptop only.

I will give it a try tomorrow because I’m away for the day.

Not sure what you mean here. Is the problem in gaming or playing video. Did you mean you are playing video and it is capped at HD? You can use the downgrade command also to downgrade your nvidia drivers.

The problem appear everywhere (in game or outside). It’s like the whole computer can’t run higher than HD. :slight_smile:

Yes i see the monitors are not showing 4k or settings.

Monitor-1: DP-1 pos: primary,left res: 2194x1234 size: N/A modes: N/A
  Monitor-2: DP-2 pos: center res: 2194x1234 size: N/A modes: N/A
  Monitor-3: HDMI-A-1 pos: right res: 2194x1234 size: N/A modes: N/A

I did succeed to downgrade the driver but I still can’t game and my monitor stay in the weird 2194w1234 resolution according to the inxi -Faz command.
Honnestly, I’m giving up. My hardware is probably too old and supported for EndeavourOS and I don’t have any AMD GPU to test.

Have you tried with just two monitors.

Yes, I turned them off but the resolution stayed the same.
Is it an issue for the os of they’re different models?

They’re all using 4k resolution but the side ones are cheaper models because I don’t use them for gaming.

Not so sure it’s an OS thing. It’s more likely hardware. If it were me i would start with one monitor and get it working properly which means not having any others plugged in. Then i would add others after one at a time. There are some issues with the 550 nvidia drivers but on my system it is working okay. I have an Nvidia GTX 1060 but only one monitor. I’m only using 1080P

Resolutions are not wrong, Inxi is showing the calculated resolutions with fractional scaling applied when it does not have a permission to access some display info. I see this on newer inxi versions where there is a combination of wayland + HiDPI displays.

If you run it with sudo it will show everything you need to know, so what is the output of

sudo inxi -Gaz

Can you post your full journal, and also what are your framerates when running glxgears and vk_cube?

Hi there,
For the monitors, I think jake99 is probably right because even if the inxi without sudo showed odd resolution they were all running in 4k for sure. I would have noticed if it wasn’t the case. I found the rootcause about the YouTube video running in HD… I had a temporary issue with my ISP, so I didn’t had enough bandwith to run 4k video.

I’m not sure disconnecting side monitors will solve the random blinking in various apps or to run my game properly but I could give it a try.
Unfortunately I had to restore the backup of my previous Win10 config, so I can’t test anything at the moment. but I will test it next week-end.

At this point, I’m wondering if I should just buy a new AMD gpu to replace my 1080 Ti.

Guess my laptop’s resolution, I’m running KDE + Wayland at 150% scale, lol



It’s 2560x1600

Anyway, regarding your question, if you can afford it, go with a new AMD card.

1 Like

If you get a new AMD card then you should probably get at least an RX 7800XT if you want something better than the 1080Ti. I think an RX 6800 is around the equivalent.

Just chiming in to say this seemed to help quite a bit for me. I’m running a 4070 on x11 and was having stuttering issues when minimizing/ maximizing certain applications (most notibly firefox and the EOS welcome menu). I did need to uninstall steam however due to a conflict with the vulkan drivers but other than that no issues. Steam also seems to have retained all my login info settings and games btw so it wasn’t even a hassle.

Just to be sure to understand, you had to reinstall Steam, not to uninstall it completely?
I hope I will find time to make tests before the week-end, I’m too frustrated by the current situation.

Correct. running sudo pacman -R nvidia-dkms nvidia-settings nvidia-utils && yay -S nvidia-535xx-dkms nvidia-535xx-utils nvidia-535xx-settings gave me an error about being unable to uninstall nvidia-utils because it would remove the vulkan drivers steam needed. Following this I ran sudo pacman -R steam and then ran the original command again, this time it installed without error. Once the drivers were taken care of I just did sudo pacman -Syu steam and it reinstalled steam again. As far as I can tell everything seems to be working, all my games are there, no need to re-sign-in and I did a quick bout of fallout 4 just to make sure everything was still working fine - it was.

Hope that helps!

Edit: just as an additional note I am using X11 and not wayland as that was having significant issues on my system

Hi, I don’t forget you for the tests here.
I will work on this tonight, I have a hard time with the dual boot so I need to troubleshoot this first (installed EOS on a disk and Windows on another but I can’t boot on EOS)