GTX 1060 Wayland Issues

Hello everyone,

I recently installed EndeavourOS and after updating everything, I proceeded to install the Nvidia driver using nvidia-inst for my Gigabyte NVIDIA GeForce GTX 1060. However, I encountered issues with Wayland—it resulted in the infamous black screen with a cursor. Even on X11, there’s noticeable lag when opening or closing windows and interacting with the system in general.

Over the past two weeks, I’ve been experimenting with various distributions because I’m still very new to Linux. Along this journey, I found that on certain distributions, such as Debian, the best approach for running this GPU smoothly is to manually install proprietary drivers and blacklist nouveau drivers, which worked flawlessly on Debian.

I stumbled upon this blog post where a moderator named @ricklinux , who also uses the same GPU, mentioned running Wayland without issues with the 550 drivers. I’m quite curious—how was this achieved?

my system info

I would greatly appreciate any advice or insights from the community on this matter. Thanks!

Wayland issues aren’t so strange, nvidia isn’t generally well supported on it, hell you can’t even run some compositors without special flags on nvidia (lookin at sway…). If someone managed to run a wayland compositor well on nvidia, then you can only really expect similar results if you’re using the same compositor as they are. And possibly the same settings too.

X11 issues are ab it odd, but not very, it could be a simple configuration issue, might need to set something in /etc/xorg.conf.d to fix it.

My system is installed directly using a live usb of endeavouros with the nvidia option. I am using Kde Plasma with GTX 1060 on Wayland. One difference i see is you are using the lts kernel which i am not and never do. Also your motherboard is a bit older. Have you checked to see if there are any Bios updates for the board?

Type: Desktop Mobo: Acer model: Predator G3610 serial: <superuser required>
    uuid: <superuser required> UEFI: American Megatrends v: P02-A2
    date: 10/31/2011

Edit: Not sure if you are using grub or systemd-boot. My grub command line has the following parameter

Edit: I don’t see that in your output but I don’t use systemd-boot so I’m not sure it shows that info the same way? I do know how to add it if using systemd-boot though. Modify kernel options:

1 Like

I’ve tried a couple times to get my Nvidia GPU (workstation A4000) and Wayland (Plasma6) to behave, following the recommended steps and such. I have seen some improvement since the initial Plasma6 release, but the web browsers are still a glitchy mess, as well as some Electron based apps.

Currently, I’m pinning some hopes on the Nvidia 555 driver release, which will finally support explicit sync. Even then, I’m not certain all will be well for Nvidia, as there are other things that also need to fall into place.

I’m using Firefox without much of any problems.

Edit: Even the cube works!

1 Like

Welcome to the forum! :smile:

Basically you don’t need to use nvidia-inst after installing, provided you selected the proprietary Nvidia option from the boot menu while installing the system.

The proprietary Nvidia driver package blacklists nouveau automatically. Perhaps you want to check if nouveau is not blacklisted:

lsmod | grep nouveau

If this shows anything, you have nouveau active which you probably do not want.

For me wayland causes problems with apps like kaffeine and virtualbox (on Nvidia). Otherwise wayland mostly works as expected, although some quite small issues here and there.
That’s why I currently use x11 instead.

1 Like

RTX3070, running Plasma Wayland, no problems at all, but you do need some kernel parameters, will post when I get home what I have.

1 Like

Alright, so I did a reinstall, and this time I opted for the latest NVIDIA Cards option instead of the default one I used previously. I also used the non-LTS Kernel this time. Guess what? It worked like a charm—I can now log into Wayland without any issues. It’s a refreshing change from my usual manual setup routine! Who would have thought that the live USB stick could handle everything for me? :slight_smile:

Now, I’m not sure if it would work with the LTS Kernel. I guess this would require further testing.

The only issue I encountered is that the pop-ups don’t open when you click on the system tray in the bottom right corner of the panel. Instead, only a little grey/black dot appears, and stretching it doesn’t seem to solve the problem. I’ve read somewhere that this is a known bug with KDE 6? Not sure if they’ve fixed it yet or not.

I will leave this post open until tomorrow, if that’s alright, so I can conduct some further testing.
After that, I will mark it as resolved. :slight_smile:

You can install both the default and the LTS kernel, they co-exist nicely in the system.
For the LTS kernel you just need to install packages nvidia-lts and linux-lts (unless you already have nvidia-dkms installed).

1 Like

What pop ups are you referring to?

i will try that, thanks :grin:

When you click on icons like the volume icon in the system tray, normally a pop-up window appears for adjusting audio input, output, and volume, or microphone settings. However, for some users, only a small dot appears instead. I actually found a good video example of this issue on this Reddit post

And apparently, there has been a bug report filed for this issue

Weird>! That’s not happening on my GTX 1060 as far as i know but I’ll double check that.

This appears to be a KDE 6 bug related to Wayland, which I’ve encountered on both Manjaro and Fedora as well. The suggested fix/solution from that Reddit post seems to work—at least it did for me. I logged out, started an X11 session, and then logged back into the Wayland session.

I’ve not noticed this. I will check mine and let you know.

Edit: Checked and verified. I have no issues with the taskbar popup windows. They all work as they are supposed to.

Okay, so far almost everything seems to be working fine. There are a couple of graphical glitches, but they can be fixed manually.
Thanks to everyone who contributed or offered their help. This thread can be closed now, and I will mark the solution.

I’m really excited to use this Distro! :grin:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.