GTK3 theme in XFCE

Hi there,

in a fresh install of EOS with XFCE I changed the theme to my beloved Qogir. Neofetch says that the gtk2 theme is in fact Qogir whereas the gtk3 theme is Adwaita. Is there a way to change the gtk3 theme, or am I missing something here?

Thanks in advance,


How did you “change” it? :grinning:

I changed it via the “Apperance” -> “Desktop” tab.

[csteinforth@EOS ~]$ xfconf-query -c xsettings -p /Net/ThemeName
[csteinforth@EOS ~]$ ls -l ".themes/$(xfconf-query -c xsettings -p /Net/ThemeName)"
insgesamt 44
-rw-r--r-- 1 csteinforth csteinforth   324 22. Apr 22:43 AUTHORS
drwxr-xr-x 1 csteinforth csteinforth    88 22. Apr 22:43 cinnamon
-rw-r--r-- 1 csteinforth csteinforth 35147 22. Apr 22:43 COPYING
drwxr-xr-x 1 csteinforth csteinforth    98 22. Apr 22:43 gnome-shell
drwxr-xr-x 1 csteinforth csteinforth   130 22. Apr 22:43 gtk-2.0
drwxr-xr-x 1 csteinforth csteinforth    76 22. Apr 22:43 gtk-3.0
-rw-r--r-- 1 csteinforth csteinforth   310 22. Apr 22:43 index.theme
drwxr-xr-x 1 csteinforth csteinforth  2788 22. Apr 22:43 metacity-1
drwxr-xr-x 1 csteinforth csteinforth    20 22. Apr 22:43 plank
drwxr-xr-x 1 csteinforth csteinforth  3768 22. Apr 22:43 unity
drwxr-xr-x 1 csteinforth csteinforth  2056 22. Apr 22:43 xfwm4

Does Qogir-win-light work?

Awaiting an answer too! It never seems to affect anything adversely (ie: I never see anything Adwaita) but my choices act the same. BTW - Qogir looks good, but I’ll stick with Ollifri’s Eye-Friendly-Dark-M-RBC for now (it’s darker) :smile:

Nope, same result in neofetch. But maybe I figured this one out. I read that this file

[csteinforth@EOS ~]$ cat ~/.config/gtk-3.0/settings.ini 
gtk-icon-theme-name = Qogir-manjaro
gtk-theme-name = Qogir-manjaro-win-light

actually changes the gtk3 theme.

Me too. Never found something Adwaitaish…

This isn’t exactly a ‘fix’ - but it would mean not having to think about it anymore :grin: In ~/.config/neofetch/config.conf

# Enable/Disable gtk3 Theme / Icons / Font
# Default: 'on'
# Values:  'on', 'off'
# Flag:    --gtk3
# Example:
# on:  'Numix [GTK2], Adwaita [GTK3]'
# off: 'Numix [GTK2]'

turning gtk3="off" would take it out of sight, out of mind…

This is all fixed in the newest version. Coming soon to a distro near you.

Let’s see what @SGS can do with this. :astonished:


1 Like



:smiley: :wink: :slight_smile:


Will EndeavourOS soon be offering this on the online installer? We even have the art work ready.

This seems to be one step closer to:
sudo make me a sandwich.



Hey i also faced the same issue just delete .config/gtk-2.0 and .config/gtk-3.0 and then do neofetch :slight_smile:
I know I am answering this after one year but this is the solution :sweat_smile:

1 Like