GTK Theme only shows when running programs as root!

This might be a dumb question but I can’t find a solution for this.
As an example, if I run nautilus it show with the default light theme. If run ‘sudo nautilus’ it will run with my dark GTK theme that I have set in lxappearance.

  • What is your DE?
  • How did you set the theme?
  • What is the theme name?
  • If can please give more details on what you did to set theme.

I use i3 wm (I did not install i3 from calamares installer, I installed it manually.)
I set my theme using lxappearance
My theme is arc-dark

I launched appearance with dmenu but it said it needs root permissions. I ran the program from my terminal with ‘sudo lxappearance’ I clicked on arc-dark (a theme I installed with the command on the GTK article on the ArchWiki. Everything including lxappearance only uses this theme if I run theme with sudo in the terminal. Please tell me what I might’ve done wrong or just tell me what the best way to install gtk themes is. thx.
Also I like your profile picture :smiley:

Can you run ‘lxappearance’ in a terminal without ‘sudo’?

I just did this myself, as I have an app that blinds me in it’s normal theme. I downloaded lxapperance-gtk3, ran it from a shell. Selected Arc-Dark (just like you). Ran my app, and it appears in the theme.

Another shot, maybe grab the neofetch package, and run it. You’ll see a Theme: entry in the stats. If it says Arc-Dark there or after you run lxappearance. If it says Arc-Dark and launching Nautilius is still light, that’d be puzzling.

1 Like

Oh wow, thanks that actually worked. Thanks.

will create gtk config for user root :wink:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.