GTK apps use dark theme and some dialogs blur in Deepin light mode

After I’ve used Deepin desktop environment for the first time, a series of weird events happened, and some persisted after I uninstalled it.

The blurred window in the middle is supposed to be the authentication window for package installing. As you can see my system is on Light but a lot of GTK apps are in dark. Even after I uninstalled deepin, deepin-extra and all their dependents, pamac is stuck in dark mode. Was there some way to fix these?

It seems Deepin has altered some GTK configuration, which is also used by every other DE.
Such configuration can be found in files/folders inside $HOME/.config/ folder.
Since you have uninstalled Deepin, I guess that it is not worth trying to find the reason of the issue.
Depending on your current desktop environment, you may be able to change such settings with that DE’s native utilities, or with the dconf editor utility.

I found the gtk-3.0 and gtk-4.0 folders and nothing else that starts with gtk. I strongly suspect that they are from KDE, and changing gtk-application-prefer-dark-theme=false didn’t work.

Create a new user and test.
You may learn a lot from comparing original and new user folders.
Archwiki has plenty info about that.

I already have a new user, and I’ve tried that already. I think now that maybe the problem’s that Pamac is Qt and I have QGnomePlatform and something somehow toggled that GNOME theme into dark mode?

Weird, I use pamac-all which claims it’s GTK? But changing GNOME to Light (Default) mode did solve the issue on pamac. The Waterfox issue was solved after a complete reinstall.

Amidst all this something I’ve done somehow managed to break MATE. Now whenever I pass SDDM I am greeted by an empty TTY screen that doesn’t do anything (the “shell” is basically just a text editor) and switching to TTY2 gives me the graphical MATE for a while before it suddenly crashes.

Edit: I don’t know what I changed but it works now?

pamac and some gtk apps like sddm-conf are dark mode now though.