GTK app font size tiny after Plasma 524 upgrade

Guys. Just noticed, that the fonts in gtk applications ( e.g. Gimp) are really tiny after I upgraded to Plasma 5.24.
Changing the font size in ~/.config/gtk-3.0/settings.ini doesn’t have any effect.
Any ideas how to increase the font size?
J.

I had a similar problem yesterday. Can you try reapplying the gtk theme in system settings

I assume you use a high dpi screen. To correctly scale it’s also possible to change .profile

appending these lines to ~/.profile or something similar. I use GTK (cinnamon) and need to scale QT apps but I assume the same can be done in KDE for GDK apps. You can change the numbers as you wish.

export GDK_AUTO_SCREEN_SCALE_FACTOR=0
export GDK_SCREEN_SCALE_FACTORS=1 

No high dpi screen, font size issues in GTK apps only.

Ok, you could try GDK_SCALE_FACTOR=2 or GDK_SCREEN_SCALE_FACTORS=2. Log out and back it and open gtk app. see if it works. If not you can easily delete from .profile folder in your home folder.

edit: btw here is some infos from the qt website for some of these commands, which I assume should work for scaling GDK apps.

High DPI Support in Qt

Qt provides the following ways for you to handle high DPI support in your application.

  • The ability to provide pixmaps or artwork for high resolution. For more details, see Drawing High Resolution Versions of Pixmaps and Images.
  • Qt 5.6 supports cross-platform high-DPI scaling for legacy applications, similar to the scaling done natively in macOS. This allows applications written for low DPI screens to run unchanged on high DPI devices. This feature is opt-in, and can be enabled using the following environment variables:
    • QT_AUTO_SCREEN_SCALE_FACTOR [boolean] enables automatic scaling, based on the monitor’s pixel density. This won’t change the size of point-sized fonts, since point is a physical measurement unit. Multiple screens may get different scale factors.
    • QT_SCALE_FACTOR [numeric] defines a global scale factor for the whole application, including point-sized fonts.
    • QT_SCREEN_SCALE_FACTORS [list] specifies scale factors for each screen. This won’t change the size of point-sized fonts. The environment variable is mainly useful for debugging, or to work around monitors with wrong EDID information(Extended Display Identification Data).The format can either be a semicolon-separated list of scale factors in the same order as QGuiApplication::screens(), or a semicolon-separated list of name=value pairs, where name is the same as QScreen::name().

Edit 2: sorry, I am always mixing which one does what. If someone can clarify that would be good, but it doesn’t hurt trying the different possibilities to learn.

Let me repeat: No high dpi screen here, no font size issues with qt apps, only gtk aps have font size issues.

The above is to scale gtk apps, doesn’t matter if you have high dpi or not (although scaling will be different)… I just gave an example from the qt site because I scale qt apps on my computer.

that obviously applies to scale gtk apps…

That doesn’t have any effect here.

Do you have an example? I can try it on mine?

1 Like

Using System Settings. There is a section for gtk applications appearance.

If changing is not possible, search for a bug at kde bugs, or create a new report.

There are no font size settings in the GTK appearance section of the system settings.

Perhaps:

https://bugs.kde.org/show_bug.cgi?id=443215

This bug specifically mentions Wayland; it may not apply if you’re not on Wayland.

1 Like

Running x11 here.

I found a way to change the font size. I had to edit the gtkrc file in the gimp theme folder. Quite inconvenient, but at least I got what I wanted.
J.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.