Gsconnect shows no devices

I have on my pc two partitions both with Endeavour. Yes, big fan ;).
One with Gnome, where GSconnect never worked. Ever.
I have no firewall and no VPN.
On my KDE partition it always worked, and keeps working flawlessly.
Am I missing any obligatory settings?
Thank you for helping.

I was checking a little the log, here there are just a few lines

nov. 17 12:25:02 NetworkManager[633]: <warn>  [1700220302.9429] device (wlan0): Activation: failed for connection 'Galaxy A71EB21'
nov. 17 12:25:02 dbus-daemon[575]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service' requested by ':1.9' (uid=0 pid=633 comm="/usr/bin/NetworkManager --no-daemon")

Doesn’t it say something useful about the fail of connection?

Is the openssl package installed on your system?

sudo pacman -Ss | grep openssl

if it isn’t:

sudo pacman -S openssl

Another thing could be, that the ports used for gsconnect ( 1716-1764 for TCP and UDP) are bind by another service.

If you have installed kdeconnect beside gsconnect try to deinstall kdeconnect and reboot, it isn’t needed. GSConnect runs by it’s own.

Thank you for helping.

Yes I have openssl installed:

$ sudo pacman -Ss | grep openssl
[sudo] Mot de passe de ply : 
core/openssl 3.1.4-1 [installé]
core/openssl-1.1 1.1.1.w-1
extra/gambas3-gb-openssl 3.18.4-3 (gambas3)
extra/perl-crypt-openssl-bignum 0.09-9
extra/perl-crypt-openssl-dsa 0.20-5
extra/perl-crypt-openssl-guess 0.15-3
extra/perl-crypt-openssl-random 0.15-10
extra/perl-crypt-openssl-rsa 0.33-3
extra/python-pyopenssl 23.3.0-1
extra/tpm2-openssl 1.2.0-1
multilib/lib32-openssl 1:3.1.4-1
multilib/lib32-openssl-1.1 1.1.1.w-1

Do you mean kde installed on the system?
No, I don’t have it, in fact in the past I already used gsconnect on Gnome.

So I should investigate around the ports… You have an idea how to do it?

It’s probably being blocked by your firewall.

Enable the kdeconnect service in the public zone of your firewall config and that should do the trick.

edit: just noticed that you said you don’t have a firewall installed. In that case, I’m not sure. GSConnect has always worked for me out-of-the-box once I’ve configured the firewall to let it through.

Yes, even for me it always worked out of the box, never further setting required.
And yes, I didn’t installed any firewall.
I’m still searching.
We can exclude at all a problem phone side? Even if with plasma all is working so good.

What’s the result of the following command on your gnome system?

pacman -Ss kdeconnect

sudo pacman -Ss kdeconnect
extra/kdeconnect 23.08.3-1 (kde-applications kde-network)

Did you install gsconnect from the AUR or from the gnome extensions homepage?

I tried the aur too, same result.
Right now I have the extension.

hm that’s really strange. No conflicting packages, no firewall. Working on kde. Atm I’ve no further idea, sorry :confused:

1 Like

And I can ping my phone and I tried to add my phone by IP.
I could have installed an app that keeps the ports busy?

Restart phone, computer and you are sure firewalld is not running? It is normally installed by default…

sudo systemctl disable firewalld
1 Like

Since I had other problems, I reinstalled the os and now all is working.
It’s just a pity I didn’t understand what it was.
Thank you for helping.