Grub update / SSD nicht mehr lesbar

Hallo liebe Leute,
vorweg: das Problem hat nur bedingt mit Endeavour zu tun, bzw Endeavour verursacht das Problem nicht. Aber da hier ja sehr schlaue und nette Menschen unterwegs sind, hoffe ich, dass sich evtl. jemand trotzdem damit auskennt. :slight_smile:

Ich habe Endeavour OS und Windows auf einer SSD im Dualboot installiert und noch eine weitere HDD fuer Daten.
Nun habe ich wegen eines Treiberfehlers Windows neu installiert, was natuerlich den Grub ausser Gefecht gesetzt hat (Es erschien grub-rescue).
Wollte den grub dann mit Endeavour OS als Live Version reparieren, aber das hat nicht funktioniert (Glaube update-grub ging nicht). Habe dummerweise nicht zu dem Zeitpunkt schon gefragt, sondern Rescatux runtergeladen, damit gebootet und den automatischen Grub-Fix durchlaufen lassen. Nach Reboot erschien dann auch wieder das Grub und ich konnte Endeavour normal starten.
Nach einer Weile erschien dann aber aus dem nichts folgende Fehlermeldung:

Nach Reboot erschien wieder nur grub-rescue.
Also Rescatux wieder rein, nochmal den Fix gestartet.
Dabei hing sich mein Laptop aber auf, bzw. stagnierte das Programm fuer min. eine Stunde. Habe den Laptop dann, weil sonst nichts mehr ging, ueber den Powerbutton ausgeschaltet (das war wohl ein Fehler).
Denn jetzt erkennt GParted im Livesystem nur noch die Daten-HDD.
Und ich bin jetzt ueberfragt, wie ich ueberhaupt noch eine Art von Zugriff auf meine SSD bekomme. :frowning:
Hat jemand vielleicht einen Ansatz?
Vielen lieben Dank im Voraus!

keine Ahnung was rescatux gemacht hat oder nicht, als estes einmal checken was mit der SSD Festplatte los ist:
LiveISO starten und mit folgendem Befehl die Festplatten anzeigen lassen:

sudo blkid

Wenn deine SSD angezeigt wird einen filesystem check machen:
sudo fsck.ext4 /dev/sdxN

Hallo Joe,
danke fuer deine Antwort. Ja, ich weiss, Rescatux ist nicht Endeavour. Schaeme mich auf etwas, dafuer hier zu fragen. Aber ehrlich gesagt bin ich nirgendwo sonst angemeldet. :see_no_evil:

Das ist eben das Problem, die Platte wird gar nicht mehr erkannt:

user@debian:~$ sudo fdisk -l
Disk /dev/sda: 698.7 GiB, 750156374016 bytes, 1465149168 sectors
Disk model: ST9750423AS
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xae14f3c6

Device Boot Start End Sectors Size Id Type
/dev/sda1 * 2048 52430847 52428800 25G 1c Hidde
/dev/sda2 52430848 681520785 629089938 300G 7 HPFS/
/dev/sda3 681521152 682444799 923648 451M 27 Hidde
/dev/sda4 682444800 1465147391 782702592 373.2G 83 Linux

Disk /dev/sdb: 14.9 GiB, 16025387008 bytes, 31299584 sectors
Disk model: Micro Line
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x04d7c2d8

Device Boot Start End Sectors Size Id Type
/dev/sdb1 * 2048 31299583 31297536 14.9G c W95 FAT32 (LB

Disk /dev/loop0: 609.6 MiB, 639225856 bytes, 1248488 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

sda ist die Daten-HDD
sdb ist der Live-USB-Stick

Wenn das Forum hier nur fuer Endeavour-spezifische Probleme bleiben soll, wuerde ich natuerlich auch in andere Foren ausweichen!

Die SSD wird wieder erkannt und läuft:
hatte sie mehrfach umgesteckt, das hat nichts gebracht.
Habe den Laptop dann auf gut Glück vollständig auseinandergeschraubt und auch den SSD-Adapter abgezogen und wieder aufgesteckt. Locker dürfte der nicht gewesen sein, da verschraubt. Merkwürdig. :thinking:
Danach jedenfalls nochmal Rescapp mit Grub-restore durchlaufen lassen, jetzt geht es wieder.
Trotzdem Danke, joe!

1 Like