Grub still quiet after removing the "quiet" option

I want to see what is happening since my laptop won’t boot with the latest kernel since some time.
It booted okay with the LTS, but todayitI took 2 attempts to boot to the desktop.

Therefore I wanted to watch the systemd lines to see if something appears but it boots still in quiet mode.

# GRUB boot loader configuration

GRUB_CMDLINE_LINUX_DEFAULT="intel_idle.max_cstate=1 resume=UUID=31fc204a-f877-4128-b63f-ac70b0d5312e loglevel=3 pci=nocrs"

Sorry if I note the obvious, but you did inform grub about the changes by running the following?
sudo grub-mkconfig -o /boot/grub/grub.cfg


Yes, I’ve removed the quiet parameter a few weeks ago and grub has been rebuild a couple of times since then.
I think it does so after every kernel update…

But I have done it once more and it seems like it wants to show me those lines.
But they are unreadable anyway, it is spitting out big rectangle white blocks.

Just a shot in the dark here, but you could try booting with the kernel option:


On a side note:

That “max_cstate=1” will disable most of the power saving the CPU can do. This is not a good idea to use. Even if you don’t care about saving power, on a laptop you might get a problem with temperatures; the fan could start being annnoying, etc.
Why is that in there?

Are you sure the current kernel doesn’t boot without appending pci=nocrs to the kernel line?

you do not mention where you were changing the grub config, was it



I have a long history with this laptop unable to boot with the latest kernel and these parameters have been advised.
I don’t bother about saving energy and there is no fan.

And Joe, it is the file you mentioned.

Have you tried the nopat option?

To each their own :wink: … but I’ll just add the following information to maybe prohibit others from using this parameter if they don’t really need to.

Your cpu has something called “C-states”. The state C0 is active when a core is running and executing instructions. When there’s nothing to do for a core, the OS puts it into C1 where it sleeps and waits until there’s something to do again.

The C1 state stops the core clock. After a while in C1, the cpu puts the core into C3, then C6 (and possibly more on newer CPUs). In the C3 and C6 states the CPU will start to cut power for different parts. Most power saving is done in those last C-states, while in C1 it will at most reduce voltage but not cut power.

During “normal” usage, when you are just doing basic tasks, like web browsing, the CPU is probably in those C3/C6 states for more than 90% of the time.

So, if you don’t absolutely need this parameter for your system to function, by prohibiting your system from entering c-states >1, you’re just stressing your components more, potentially reducing life expectancy. You will have a higher energy bill too - all without any performance benefit.

1 Like

I assume that my laptop is affected by the intel-gpu disaster that is haunting the linux castle.
There are lots of issues known according to this.

But I could try those 2 options and see what happens.

I don’t even recall what the original line looks like. :roll_eyes: