GRUB Sometimes Fails Due to no such device error

New EOS user here. I recently installed EOS on an external SSD to use alongside windows 11. Initially everything worked fine but suddenly out of nowhere GRUB started failing due to an unknown filesystem error. This happens almost always when I boot into both Windows and EOS.
The weird thing is that i can still boot into either OS by rebooting once or twice.

I tried following online guides to fix the error in GRUB by reinstalling it from EOS, recreating the config file, and trying to fix it through grub rescue( all partitions came up as unknown filesystem ).

Finally I tried just clean installing both Windows and EOS but the issue still persists.

Any help would be appreciated.

Have you tried to arch chroot into the installed system and reinstall grub and before updating it make sure that os-prober line in the grub file is uncommented.


Edit: Also in Bios make sure it is booting from the correct drive where EOS is installed.

1 Like

The problems seems to be in the BIOS boot settings as you mentioned. Changing the boot location fixed the issue. Sort of. I can now boot into either OS through grub itself. Though windows still isn’t booting properly if I don’t connect my external drive(same error as original post) even after I set windows as first in boot priority and set it to the windows bootloader.
I don’t switch between EOS and windows much so I guess I’ll stop messing around with grub before I mess up anything. Thank you for your help. I’m going to try reinstalling grub after reading up a bit. I can copy and paste the commands to reinstall but I’ve got no idea what they do yet.
Thank you for your help!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.