Grub rescue - unable to boot into any OS

When I was booted into Windows. I shrank the volume of the Window’s partition (while the OS was running) and I created a new partition. I did not shrink any of the Linux’s paritions. After a little while I deleted the newly created partition and reclaimed the unallocated space back into the Window’s partition. After a reboot Grub cannot detect any of the operating systems and it shows unknown file system grub rescue message. I can still boot into Windows by using the boot options on the BIOS. How do I fix Grub? Also I can not boot into EndeavourOS through the boot options.

Found this: https://www.howtoforge.com/tutorial/repair-linux-boot-with-grub-rescue

and

https://www.supergrubdisk.org/rescatux may be of some help…

1 Like

Hey man this partially works.

So I did ls and tried to find all the partitions that are supported. So in my case (hd0,gpt4) was the one that has a known filesystem.

So then I typed these commands out.

boot=(hd0,gpt4)
prefix=(hd0,gpt4)/boot/grub
insmod normal
normal

And I did end up starting up grub. So after I booted into EndeavourOS, I reinstalled grub (sudo pacman -S grub) But after a reboot it does the same thing again.

Does boot-repair exist in the ArchLinux repo?

You can also boot from installer ISO and arch-chroot into installed EndeavourOS, from there you can reinstall grub.
https://endeavouros.com/docs/system-rescue/rescue-non-booting-system-with-arch-chroot/

1 Like

Thanks for your post, I just saw it after I recovered my PC. I didn’t use chroot

I followed this and it worked.

3 Likes

Wow! Nice, I will have to remember that video so when I FooBar I can fix it, :slight_smile:
Thanks for the video…
This forum never ceases to amaze me! So many great minds willing to help!
I keep spreading the work about this great group! :grin: :grin: :grin: :vulcan_salute:
LLAP

1 Like

No worries :slight_smile: The only thing that will not work is typing in sudo update-grub, this is a debian based command and will not work on Arch so just skip that 2nd last step.

Its one of the best forum groups :slight_smile:


By the way would you happen to know where does the bootloader exactly get installed?

Yep, I noticed that as I do have several OS’s and several are debian based. I know how to fix grub once I get into the desktop, just not how to get there sometimes… Lol
Hmmm, I’m not sure, I think it is in the /boot but not sure as I tend to stay out of there… :open_mouth: :slight_smile:
LLAP

Oh I see :slight_smile:

Hmm, see if it is inside the /boot why does it screw up if I play around with the partitions? That is what I don’t get?

To be honest, I don’t “Dual Boot” anything and only did once and it got fooBar by Windows 10 update and it too 2 days to fix, (was new to linux then) I said that sucked and have always used 2 hard drives, 1 for Windows and 1 for Linux… Now days the only Window in my house are in the walls to let sunshine in… lol Now if I want to Linux Distros on one computers, I use the 2 Hard Drive’s one for each… :vulcan_salute: Take care!
LLAP

1 Like

What is fooBar?

:laughing: :laughing:

:+1:

You too mate :slight_smile:

@unix_lover
Thank you for that video tutorial.

I’ve created a new wiki page with a video tutorial that handles both Grub rescue and Arch-chroot, this one is more targeted to Arch audiences and explains the commands and actions a bit better.

https://endeavouros.com/docs/system-rescue/repair-grub-with-grub-rescue-and-arch-chroot/

6 Likes

You’re welcome :slight_smile:

Oh nice I should take a look at it the next time Grub decides to not work properly :slight_smile:

3 Likes

Well @unix_lover, it is in reference to a old american movie that had Kurt Russel was in it where he was in a bad spot because something was screwed up real bad and he called it “FooBar” and the guy asked him what it meant and he said “It means F***ed Up Beyond Recognition”… Can’s say the bad word but I think you get it… Lol
So here in the states we call something that got broke or is going to get broken, “FooBared”… :slight_smile:
Just some more of the american slang words. Even Stranger, it does not always mean the same from one coast to the other coast… :rofl: :sweat_smile: :laughing: :joy:
American slang words vary in meaning from one part of the same state to the other part. Let alone from state to state… Lol
In Tennessee they don’t “Take someone somewhere” they “Carry them” (Will you carry me to the store?) Being from the North it took me a bit to get use to that on for sure…
BTW, The Correct spelling is “FuBar” here in Indiana where I am we use FooBar… Country Hicks Lol
Americans, go figure! LOL
“SORRY FOR BEING OFF TOPIC”
LLAP

4 Likes

@unix_lover and for all who face recurring issue after they followed upto normal command.

Please use @joekamprad command in next comment.

Simply open terminal once you are in EndeavoursOS and enter following commands:

  1. sudo grub-mkconfig -o /boot/grub/grub.cfg
  2. sudo grub-install /dev/sda

This will stop the recurring grub rescue screen as you just reinstalled grub with new config file.

2 years later …
2yl

and not a good info anyway… most users will run on uefi/EFI system where your command is not what you need to use and it needs this instead:

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS-grub

And we have grub covered in the wiki:
https://discovery.endeavouros.com/system-rescue/repair-a-non-booting-grub/2021/03/

closing

2 Likes