Grub not recognizing amducode/manual entry doesn't show up in uefi bios

Okay so I had rebuilt my system from intel to amd. I had both ucodes. I removed intel, now while amd-ucode.img is in my boot folder grub doesn’t detect it when i run mkconfig. A guy on the telegram group had me run this:

[lazarus@Minerva boot]$ sudo efibootmgr --disk /dev/sda --part 1 --create --label “endeavour test” --loader /vmlinuz-linux --unicode ‘root=/dev/long/ruut rw initrd=\amd-ucode.img \initramfs-linux.img’ --verbose
[sudo] password for lazarus:
BootCurrent: 0002
Timeout: 1 seconds
BootOrder: 0001,0002,0000
Boot0000 Windows Boot Manager HD(1,GPT,fb893690-7b8d-4952-96ac-dd0ef354676b,0x800,0x200000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)䥗䑎坏S
Boot0002* endeavour HD(1,GPT,fb893690-7b8d-4952-96ac-dd0ef354676b,0x800,0x200000)/File(\EFI\ENDEAVOUR\GRUBX64.EFI)
Boot0001* endeavour test HD(1,GPT,16ee00b9-f662-4ee5-aa22-ac7774110b1a,0x800,0x73227732)/File(\vmlinuz-linux)root=/dev/long/ruut rw initrd=\amd-ucode.img \initramfs-linux.img
[lazarus@Minerva boot]$

This is what I get when I run

[lazarus@Minerva boot]$ sudo efibootmgr -v
BootCurrent: 0002
Timeout: 1 seconds
BootOrder: 0003,0001,0002,0000
Boot0000 Windows Boot Manager HD(1,GPT,fb893690-7b8d-4952-96ac-dd0ef354676b,0x800,0x200000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS…x…B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}…8…
Boot0001* endeavour test HD(1,GPT,16ee00b9-f662-4ee5-aa22-ac7774110b1a,0x800,0x73227732)/File(\vmlinuz-linux)r.o.o.t.=./.d.e.v./.l.o.n.g./.r.u.u.t. .r.w. .i.n.i.t.r.d.=…a.m.d.-.u.c.o.d.e…i.m.g. …i.n.i.t.r.a.m.f.s.-.l.i.n.u.x…i.m.g.
Boot0002* endeavour HD(1,GPT,fb893690-7b8d-4952-96ac-dd0ef354676b,0x800,0x200000)/File(\EFI\ENDEAVOUR\GRUBX64.EFI)

but when I reboot to uefi to boot endeavour test it is missing and doesn’t show up when I run efibootmgr -v from the rebooted system.

Sounds similar to your problem with LVM, so, let me ask you a pertinent question:
Is this a fresh install on AMD or did you just move your HD to this computer from your Intel unit? The reason I asked is because I did something similar moving from AMD to Intel. I could still boot into the old system but I found too many leftovers including references to BIOS and equipment that is not on the new computer. If that is the case, I hope you have a good backup of your Home so you can make a fresh install. That would solve all of your problems.

Basically I rebuilt from an Intel system to an amd system and through my existing lvm2 system in there. This is preferable to me as I have things like antergos themes I can no longer get, but, mainly because I have a complex lvm2 system without luks and given calamares problems manually partitioning an install, I am loathe to try it. I have a seperate home, data, and, var partitions that all have to be carried over. In cnchi this was never a problem, but, I have seen many people complaining about partitioning issues at install.

Make a new stick with Gparted, backup and do it right. I agree, partitioning with Calamares is not ideal.

What do you mean do it right. I have no wish to reinstall. There has to be a way to fix it without nuking what I have. My system is solid except not noticing amd-ucode.

No comment.

That isn’t very constructive.

And I made a new stick last night and it keeps dropping internet.

To make sure you have it installed, what does

pacman -Q amd-ucode

show?

And could you show the generated file /boot/grub/grub.cfg, especially the part that should have amd-ucode.img (the initrd line)?

[lazarus@Minerva boot]$ pacman -Q amd-ucode
amd-ucode 20191022.2b016af-1

BEGIN /etc/grub.d/10_antergos

menuentry ‘EndeavourOS Linux’ --class endeavouros --class gnu-linux --class gnu --class os $menuentry_id_option ‘gnulinux-simple-4222cddf-a4ca-4f88-982d-7ef6c22fec32’ {
load_video
set gfxpayload=keep
insmod gzio
insmod part_gpt
insmod part_gpt
insmod part_gpt
insmod lvm
insmod ext2
set root=‘lvmid/sIYc5z-PXN0-w05X-4X2N-4qCu-NeGh-pm3Kug/jr26eX-AyPq-M0Kh-QQM6-0LjB-4FGJ-3lnnZz’
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint=‘lvmid/sIYc5z-PXN0-w05X-4X2N-4qCu-NeGh-pm3Kug/jr26eX-AyPq-M0Kh-QQM6-0LjB-4FGJ-3lnnZz’ 4222cddf-a4ca-4f88-982d-7ef6c22fec32
else
search --no-floppy --fs-uuid --set=root 4222cddf-a4ca-4f88-982d-7ef6c22fec32
fi
echo ‘Loading linux kernel …’
linux /boot/vmlinuz-linux root=/dev/mapper/long-ruut rw quiet resume=UUID=47157dcf-4a00-4b7b-bbd9-024925371351
echo ‘Loading initial ramdisk …’
initrd /boot/initramfs-linux.img
}
submenu ‘Advanced options for EndeavourOS Linux’ $menuentry_id_option ‘gnulinux-advanced-4222cddf-a4ca-4f88-982d-7ef6c22fec32’ {
menuentry ‘EndeavourOS Linux, with linux Kernel’ --class endeavouros --class gnu-linux --class gnu --class os $menuentry_id_option ‘gnulinux-linux-advanced-4222cddf-a4ca-4f88-982d-7ef6c22fec32’ {
load_video
set gfxpayload=keep
insmod gzio
insmod part_gpt
insmod part_gpt

that is after uninstalling ucode clearing the cache and then reinstalling with -Sy. Afterwards running the mkconfig command. I used both -Rns and Rdd to remove it, -Sc to clear the cache, -Syyu, and finally -Sy to reinstall, mkconfig. that is exactly what I did for grub. I also tried adding the line
GRUB_EARLY_INITRD_LINUX_CUSTOM=/boot/amd-ucode.img
to my /etc/default/grub and regenerating.

You do not need internet to clean up a partition and you do not need to ruin the rest of your HD, just erase the partitions containing UEFI and EOS, reformat them individually, don’t forget to change the flags for UEFI to boot/esp, then reinstall while doing the manual recognition of your Home etc.

Could you generate grub.cfg again:

sudo grub-mkconfig -o /boot/grub/grub.cfg

Does that show the initrd line correctly?

EDIT: I don’t think GRUB_EARLY_INITRD… variable is needed.

That is too easy. I want to fix what I have not nuke it. I pride myself on not reinstalling everytime something comes up, but, figuring it out and sometimes asking advice. If no one has better advice by the 15th I will reinstall, but, I can’t back up 4 TB and I there are things I can no longer download like antergos’ Numix themes I don’t want to use. This is the first problem I have had. There is nothing in uefi about the old system, and, I havn’t seen any evidence of other hangers on you describe.

See above,

I removed the variable and tried i both ways already, but, here it is again.

[lazarus@Minerva boot]$ sudo grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file …
Found theme: /boot/grub/themes/EndeavourOS/theme.txt
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/initramfs-linux.img
Found fallback initramfs image: /boot/initramfs-linux-fallback.img
Found linux image: /boot/vmlinuz-linux-lts
Found initrd image: /boot/initramfs-linux-lts.img
Found fallback initramfs image: /boot/initramfs-linux-lts-fallback.img
Found Windows Boot Manager on /dev/sdb1@/EFI/Microsoft/Boot/bootmgfw.efi
done

and the result

linux /boot/vmlinuz-linux root=/dev/mapper/long-ruut rw quiet resume=UUID=47157dcf-4a00-4b7b-bbd9-024925371351
echo ‘Loading initial ramdisk …’
initrd /boot/initramfs-linux.img

theme’s are in /usr which gets wiped. I am not going to format my esp as I have windows that I sometimes use to download a linux iso in an emergency or root my phone. I don’t understand what other partition you could mean by uefi uefi is uefi bios not on a partition but the motherboard.

if you mean /boot/efi just no.

You are using Antergos grub?

I followed the instructions on the forum to change from antergos to Endeavour os. the entries are endeavour as is the theme. Everywhere else in the system it says endeavour.