GRUB not appearing after installing endeavourOS `dual-boot`

I’ve recently installed endeavourOS but after i restart when i finish my installation there seems to be no GRUB, it isn’t present in the BIOS order
tried disabling secure boot/fast boot, nothing worked
tried solutions from youtube & similar posts here, Didn’t do anything
also tried installing in leagcy and UEFI same result, Windows Boot Manager Also only shows win10


> BootCurrent: 0006
> Timeout: 0 seconds
> BootOrder: 2001,2002,2003,0003,0005,0004,0000
> Boot0000* Realtek PXE B02 D00   BBS(128,Realtek PXE B02 D00,0x0)feff0200000000000000000000000200af0000d080000000c10b00d0920100d0000000000000000000000000000000000000000000000000000000000000000000000000001100
> Boot0001* EFI PXE 0 for IPv4 (00-2B-67-90-1F-60)        PciRoot(0x0)/Pci(0x1d,0x0)/Pci(0x0,0x0)/MAC(002b67901f60,0)/IPv4(,0,0)RC
> Boot0002* EFI PXE 0 for IPv6 (00-2B-67-90-1F-60)        PciRoot(0x0)/Pci(0x1d,0x0)/Pci(0x0,0x0)/MAC(002b67901f60,0)/IPv6([::]:<->[::]:,0,0)RC
> Boot0003* TOSHIBA MQ01ABD100                    BBS(HD,TOSHIBA MQ01ABD100              ,0x500)feff00000000170000000000000001062d00e4e8020000051900e4e84100e4e8000000020000000000000000000000000000000000000000000000000000000000985d1a8f120002010c00d041030a0000000001010600001703120a000000000000007fff0400
> Boot0004* PLDS    DVD-RW DA8AESH                BBS(CDROM,PLDS    DVD-RW DA8AESH          ,0x500)feff00000000170000000000000001062d00ebe8030000051900ebe84100ebe8000000130000000000000000000000000000000000000000000000000000000000185e1a8f130002010c00d041030a0000000001010600001703120a000100000000007fff0400
> Boot0005* ADATA   USB Flash Drive       BBS(HD,ADATA   USB Flash Drive ,0x500)feff0000000014000000000000000c0300005de80200000500005be800005fe8000000000000000000000000000000000000000000000000000000000000000000a023158f140002010c00d041030a00000000010106000014030506000c007fff0400
> Boot0006* EFI USB Device (ADATA   USB Flash Drive)      PciRoot(0x0)/Pci(0x14,0x0)/USB(12,0)/HD(1,MBR,0x4e4305b5,0x4d5940,0x4e800)RC
> Boot2001* EFI USB Device        RC
> Boot2002* EFI DVD/CDROM RC
> Boot2003* EFI Network   RC


> loop0    7:0    0   2.3G  1 loop /run/archiso/airootfs
> sda      8:0    0 931.5G  0 disk 
> ├─sda1   8:1    0    50M  0 part 
> ├─sda2   8:2    0 292.9G  0 part 
> ├─sda3   8:3    0 443.2G  0 part 
> └─sda4   8:4    0 195.3G  0 part 
> sdb      8:16   1  14.5G  0 disk /run/archiso/bootmnt
> ├─sdb1   8:17   1   2.4G  0 part 
> └─sdb2   8:18   1   157M  0 part 
> sr0     11:0    1  1024M  0 rom

Please use the code tag </> for formatting terminal output.

Highlight the pasted text and press Ctrl-E.

Can you share the output of sudo parted -l

Model: ATA TOSHIBA MQ01ABD1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  53.5MB  52.4MB  primary  ntfs         boot
 2      53.5MB  315GB   315GB   primary  ntfs
 3      315GB   790GB   476GB   primary  ntfs
 4      790GB   1000GB  210GB   primary  ext4

Model: ADATA USB Flash Drive (scsi)
Disk /dev/sdb: 15.5GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size   Type     File system  Flags
 2      2595MB  2760MB  165MB  primary  fat16        esp

You are legacy booting that device. The partition didn’t get flagged as boot. I am curious what was chosen in the installer to create that scenario.

i dont know what you mean, but i loaded the usb while i was on UEFI Mode on bios,everything in the installer was default kde plasma, and then i replaced the unallocated partition with endevaourOS

note: in my bios my hard drive doesnt appear when i switch to UEFI do i have to format my drive or smth

drive is in msdos partition scheme, not gpt this indicates windows is already installed in legacy mode.

fixed: I reinstalled EndevaourOS after changing the bios to UEFI and running the command mbr2gpt on Windows. And GRUB works as planned.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.