Grub-mkconfig not detecting grub-btrfs snapshots

Hello,

I recently installed Endeavour and I am loving it. This is also my first post. I found this article on the wiki, https://discovery.endeavouros.com/encrypted-installation/btrfs-with-timeshift-snapshots-on-the-grub-menu/2022/02/, and I have worked to get this configured and I have failed so far.

So here is where I currently stand. I edited /etc/systemd/system/grub-btrfs.path and changed the [PathModified] from /run/timeshift/backup/timeshift-btrfs/snapshots to PathModified=/run/timeshift/backup/timeshift/snapshots

[Unit]
Description=Monitors for new timeshift snapshots
DefaultDependencies=no
Requires=run-timeshift-backup.mount
After=run-timeshift-backup.mount
BindsTo=run-timeshift-backup.mount

[Path]
PathModified=/run/timeshift/backup/timeshift/snapshots

[Install]
WantedBy=run-timeshift-backup.mount

I changed this PathModified as the timeshift-btrfs directory did not exist

[usr@arch-t470s backup]$ pwd
/run/timeshift/backup
[user@arch-t470s backup]$ ls
drwxr-xr-x - root 20 May 16:26  @
drwxr-xr-x - root 20 May 10:50  @cache
drwxr-xr-x - root 20 May 10:50  @home
drwxr-xr-x - root 23 May 16:56  @log
drwxr-xr-x - root 22 May 22:36  timeshift

I then reenable the service and it gives a warning that the grub-btrfs.path is added as a dependency to a non-existing unit.

[user@arch-t470s backup]$ sudo systemctl reenable grub-btrfs.path
Removed "/etc/systemd/system/run-timeshift-backup.mount.wants/grub-btrfs.path".
Created symlink /etc/systemd/system/run-timeshift-backup.mount.wants/grub-btrfs.path → /etc/systemd/system/grub-btrfs.path.
Unit /etc/systemd/system/grub-btrfs.path is added as a dependency to a non-existent unit run-timeshift-backup.mount.

I try running grub-mkconfig anyways and it still does not find any of the snapshots.

[user@arch-t470s backup]$ sudo grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Found theme: /boot/grub/themes/EndeavourOS/theme.txt
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Windows Boot Manager on /dev/nvme0n1p1@/efi/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for UEFI Firmware Settings ...
Detecting snapshots ...
No snapshots found.
If you think an error has occurred , please file a bug report at " https://github.com/Antynea/grub-btrfs "
Unmount /tmp/grub-btrfs.1EnykrUvNx .. Success
done

Any ideas as to what I need to change in my configuration to get grub to read my snapshots?

Pardon me if I am totally out of my depth but won’t

/timeshift/backup/timeshift-btrfs/snapshots

be created “on-the-fly” whenever Timeshift is run?

It doesn’t appear to be. I installed timeshift-autosnap and it looks like when timeshift-autosnap is run each time I do a system update (sudo pacman -Syu) or install an app through bauh, it’s putting the snapshots in /run/timeshift/backup/timeshift/snapshots instead of /run/timeshift/backup/timeshift-btrfs/snapshots.

I just figured it out. Timeshift was set to rsync and not to btrfs backups. I modified that and running grub-mkconfig now loads the snapshots.

1 Like

It’s been a while I used Timshift + grub-btrfs.
Even back then I didn’t use timeshift-autosnap.

I have taken a look at

https://gitlab.com/gobonja/timeshift-autosnap/-/blob/dev/timeshift-autosnap

and I am not seeing that it should modify the default path of Timeshift.

Please wait for some more input and perhaps have a look here:

https://gitlab.com/gobonja/timeshift-autosnap

in the meantime.

Good luck and welcome to EnOS’ community!
:enos_flag:

Edit: I totally missed your latest post :sweat_smile:
Glad you got it working!

Months later… and I have now run into this issue as well. However, my timeshift is set to BTRFS and it still gives me the same error.


image

Thanks. Will check it out right now :face_exhaling: :face_with_monocle:

Ok. So like pretty much everything in Arch, using

sudo downgrade *package name*

will fix your most issues temporarily.

Thanks for the link to the fix @mcury

1 Like