Grub missing all boot entries but "UEFI Firmware Settings" after update (Solved)

I performed an update on June 13th, 2023 to my ASUS G14 laptop. During the update run through a terminal session in Plasma, my screen went blank and I was dumped to the terminal. Thinking the update might have been interrupted, I reran the update command from the terminal but it completed showing no errors and everything as being updated.

Upon rebooting, all of my boot menu entries were gone save for “UEFI Firmware Settings”. This is on an encrypted disk with a separate UEFI partition (all setup via the installer). When I first power on the laptop, it asks me to decrypt the disk before Grub shows up. I enter in my password and then it brings me to the grub menu (see first screenshot). I now have no boot entries other than “UEFI Firmware Settings”.

In troubleshooting, I have booted from a live USB, decrypted my disk, mounted both it and the UEFI boot partition and then arch-chrooted in. I took several screenshots (below) to show the various things I have looked at to try to figure this out. I have gone over documentation from the Arch Wiki and other web pages to try to figure this out but no luck though I confess, I am not a great Linux troubleshooter. I’ve taken pictures (sorry for no clear screenshot grabs, laptop isn’t connect to the Internet) to show what i have investigated. From everything I can tell, the boot menu entries are there in both my grub.cfg and the different Linux Kernels are are detected when I update grub. From here, I’m at a loss on what I am missing.

In my pictures, I tried to include as many images as possible to show what I think is relevant. Assistance is greatly appreciated!

First off:

Please post text output as text and not screenshots.

Copy, paste,highlight and press CTR-E to format.

From the last line in your last screenshot, it looks as if you have used or are using Grub Customizer.
That may most probably be the cause of the issue you are having.

You could try rebuilding your Grub environment.

In chroot:

mv /etc/grub.d /etc/grub.d.old

pacman -S grub

grub-mkconfig -o /boot/grub/grub.cfg

He wrote above:

He cannot open the forum in this laptop without internet.

I guess he could save the output in a text file and post its content from where he posted the pictures?

did you enable os prober?

That is possible, but it requires two USB sticks.

  • Use the first USB stick for arch-chroot.
  • Use the second USB stick for copy&paste the output, then connect it to his other device with internet.


Thanks, I did as you suggested and that did the trick.

mv /etc/grub.d /etc/grub.d.old
pacman -S grub
grub-mkconfig -o /boot/grub/grub.cfg

Boot menu showed all of the missing options. To test Grub Customizer to see if that indeed was the issue, I reran it and made some changes, saved and then rebooted. It still worked fine, all the boot entries are still there. I then ran

grub-mkconfig -o /boot/grub/grub.cfg

to see if that error message came back after running Grub Customizer and it did not.

[robert@robert-laptop:~]$ sudo grub-mkconfig -o /boot/grub/grub.cfg
[sudo] password for robert: 
Generating grub configuration file ...
Found theme: /boot/grub/themes/EndeavourOS/theme.txt
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot:  amd-ucode.img initramfs-linux-zen-fallback.img
Found linux image: /boot/vmlinuz-linux-lts
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux-lts.img
Found fallback initrd image(s) in /boot:  amd-ucode.img initramfs-linux-lts-fallback.img
Found linux image: /boot/vmlinuz-linux-g14
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux-g14.img
Found fallback initrd image(s) in /boot:  amd-ucode.img initramfs-linux-g14-fallback.img
Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.
Adding boot menu entry for UEFI Firmware Settings ...

Looks like my problem is solved for now. Thank you for your help. Now I just need to figure out why I have such poor battery life on this install compared to the LiveUSB disk I have been using while trying to troubleshoot this problem.

You have to trust the given advice that it was indeed Grub Customizer.

The tricky thing is that it can hit you in times you won’t expect, in case you keep it installed, even if you don’t use it.

You’ve been warned! :warning:


1 Like