GRUB Menu not showing

Hi everyone, I’m new to Endeavour OS. I recently installed Endeavour OS i3wm and it’s by far the best out of the box experience I’ve had with i3. Only thing is, the GRUB menu won’t show up during startup. I don’t know/remember what I did wrong. I’ve tried every other suggestions I can find like editing various config items, changing the boot order via efibootmgr (which works but still not showing GRUB menu). All I see is a blank screen with something like “Starting Arch kernel version 5.19.11” at the top, followed by the display manager (lightdm).
Some info about my setup:

  1. I’m multi-booting an old Intel iMac (OS X + openSUSE + endeavourOS + Fedora).
  2. Each distro/OS has its own EFI partition and root partition. No mixing boot loaders.
  3. I install rEFInd on the Mac EFI partition. It recognizes and shows all the distros/OS’s.
  4. For Endeavour OS, I choose btrfs filesystem, install snapper-support, snap-pac, btrfs-grub. Everything works as expected, snapper ls shows snapshots, grub-mkconfig command updates and shows the correct number of snapshots, snap-pac’s pre & post transaction hooks work as expected.

As stated, the only thing that’s missing is the GRUB menu. I really want to enable booting from snapshots in the GRUB menu.

Here’s what usually happens for other distros: For example, startup —>rEFInd menu → select openSUSE → openSUSE GRUB menu → Entries/Boot from snapshots etc -->…etc

Here’s what’s currently happening for EndeavourOS: startup → rEFInd menu → select EndeavourOS → black screen with “Starting arch kernel 5.19.10…” → Display Manager (lightdm) → Login
(No GRUB menu! :frowning_face:)

Here’s what I expect for endeavourOS: startup → rEFInd menu → select EndeavourOS → EOS GRUB Menu → Entries/Boot from snapshots etc -->…etc

Any help/suggestions would be highly appreciated. Thanks in advance!

Welcome @nescaffe

I think you need to install grub-btrfs on EndeavourOS and update grub with sudo grub-mkconfig -o /boot/grub/grub.cfg

If you are using rEFInd and booting EndeavourOS with the grubx64.efi on rEFInd then it will be booting from grub and the btrfs snapshots should show in the grub menu.

Thanks for the quick response! I’m 100% sure I’ve done exactly what you said. Is there any information I can provide that would help troubleshoot this issue?

This is how i triple boot or more using rEFInd myself and booting from grub.

Just check the grub-btrfs is installed.

pacman -Ss grub-btrfs

Make sure you updated grub

sudo grub-mkconfig -o /boot/grub/grub.cfg

reboot and check

Yup! It really is a great way to multi-boot.

Just to eliminate a possible cause:

In the /etc/default/grub do you have the following:

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.


$ pacman -Ss grub-btrfs
community/grub-btrfs 4.11-2 [installed]
Include btrfs snapshots in GRUB boot options

$ sudo grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file …
Found background: /usr/share/endeavouros/splash.png
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot: intel-ucode.img initramfs-linux-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found snapshot: 2022-09-23 03:34:46 | @snapshots/1/snapshot | pre | pacman -S ranger |
Found 49 snapshot(s)
Unmount /tmp/grub-btrfs.Hal43BGyBT … Success

So if you rebooted do they show up now?

Yeah. First thing I did!

1 Like

Just about to…brb

I use a different setup. btrfs-assistant, snapper, snap-pac.

I’m back. Still no GRUB menu :frowning:
“I use a different setup. btrfs-assistant, snapper, snap-pac.”
Could you give me a quick run down how it all ties together especially btrfs-assistant. Is booting from GRUB possible using btrfs-assistant? Thanks.

As i said i have used triple boot using rEFInd with btrfs-assistant, snapper and snap-pac. You have full control with btrfs-assistant to create snapshots, delete and restore. I know you can add grub-btrfs and have the snapshots show up in grub and boot into snapshot but I’m not sure if you can do more from there? I’m not really knowledgeable on btrfs because there seems to be so many options and packages you can use. Not sure about all the things about it.

This is what it looks like.





1 Like

I’m not sure what snapper-support gives you? I just have snapper installed with snap-pac and then i use btrfs-assistant with it.

Edit: I have tried different variations with btrfs and i like as simple as possible. I have used grub-btrfs before also.

Thanks again for the response. btrfs-assistant does look interesting. I guess I’m going down another rabbit hole.

Yes…that is the problem. For me i just want the simplest way of doing something that i can understand and use. There are so many ways of doing things and i don’t like convoluted methods. Some stuff is just beyond what i want to deal with. I’m not a pro Linux user by any stretch.

"I’m not sure what snapper-support gives you? "

Yeah, I see what you mean. It just simplifies the snapshot config creation etc. Like you said, at a glance, btrfs-assistant seems promising. I’m gonna go on deep dive.
Anyways, should I closed this thread as solved?

1 Like

Is up to you. I just wanted to try to help. Not sure why the snapshots aren’t showing up in grub. You may not have the service enabled for that because you are using a different set up. I think btrfs-assistant does a lot of the stuff required? I’m not the expert on that but you could touch base with @dalto as he is the btrfs pro and it is his app.

Edit: So i was meaning this for grub-btrfs. I’m not sure you need to enable this service?

systemctl enable grub-btrfs.path
systemctl start grub-btrfs.path  # In case the mount point is available already

" I just wanted to try to help"
Yeah man, I really appreciated it. Like I said before, I’m new around here. Hoping to stay around longer. I’m gonna try to get help from @dalto .Anyways, thanks for the help. Now I have something to chew on.
I’m closing this thread as SOLVED.