Grub issues, switching to systemd-boot: some issues

After modifying some parameters in /etc/default/grub, I get the following errors when trying to update the grub:

grub-mkconfig -o /boot/grub/grub.cfg 
Generating grub configuration file ...
cut: invalid option -- 'f'

I am not sure where I have to look for troubleshooting this. I have recreated my whole Grub environment from scratch but to no avail.

Do you have something in the grub.d directory?

Have you tried reinstalling grub? To be clear, I mean the package grub.

Please show the file! :wink:

I do. All the “default” stuff. Haven’t changed anything in there.

ls /etc/grub.d
00_header  10_linux  20_linux_xen  30_os-prober  30_uefi-firmware  40_custom  41_custom  README

Yes.

this is a fresh one after reinstalling grub
# GRUB boot loader configuration

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Arch"
GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet"
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.
GRUB_TIMEOUT_STYLE=menu

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.
#GRUB_SAVEDEFAULT=true

# Uncomment to disable submenus in boot menu
#GRUB_DISABLE_SUBMENU=y

edit-- @dalto, @manuel, this is happening in one of my Arch install. If you think I should be posting on Arch forum, I’ll do so.

Never mind folks. I had thought to do a new install with systemd-boot this weekend. Perhaps this is the sign I was waiting for :wink:. So I am going to wipe out the whole disk now and build it up from scratch. Though it bothers me that just out of the blue I got that “error message”.

Hi,

I have tried to reinstall my system with systemd-boot but I don’t seem to get it to work.

There is something I miss but I cannot pinpoint it. I suspect there is something in /boot/loader/loader.conf or /boot/loader/entries/arch-gnome.conf which is not correctly specified. Here is some info:

parted -l

Model: Samsung SSD 970 EVO 500GB (nvme)
Disk /dev/nvme0n1: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name  Flags
 1      1049kB  1075MB  1074MB  fat32                 boot, esp
 2      1075MB  492GB   490GB   btrfs
 3      492GB   500GB   8590MB  linux-swap(v1)        swap

/boot/loader/loader.conf

timeout 5
#console-mode keep
default arch-gnome.conf
editor yes
auto-firmware 1

/boot/loader/entries/arch-gnome.conf

title   Arch Linux
linux   /vmlinuz-linux-zen
initrd  /intel-ucode.image
initrd  /initramfs-linux-zen.img
options rw rootflags=subvol=@arch-gnome-root

/etc/fstab

# Static information about the filesystems.
# See fstab(5) for details.

# <file system> <dir> <type> <options> <dump> <pass>

# /dev/nvme0n1p1
UUID=BCD6-459F      	/boot     	vfat      	rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro	0 2

# /dev/nvme0n1p2
UUID=1d9646ea-0edf-423b-85a7-88a429c6314b	/         	btrfs     	rw,relatime,compress=lzo,ssd,discard=async,space_cache,subvolid=256,subvol=/@arch-gnome-root	0 0

# /dev/nvme0n1p2
UUID=1d9646ea-0edf-423b-85a7-88a429c6314b	/home     	btrfs     	rw,relatime,compress=lzo,ssd,discard=async,space_cache,subvolid=257,subvol=/@arch-gnome-home	0 0

I would really appreciate if you could point me to the right direction. I am stuck here and can’t go forward not finding what is wrong

Suffix for intel-ucode should be img…

3 Likes

You need to add the root, typically something like root=UUID=1d9646ea-0edf-423b-85a7-88a429c6314b

2 Likes

one thing you shouldnt have is

editor yes

This would allow someone to gain root access without a password

otherwise your options look a bit off as @dalto pointed out

1 Like

No need for this:

rootflags=subvol=@arch-gnome-root

in addition to root=UUID= ?

You need both. root= tells it where the root partition is. rootflags=subvol= tells it which subvolume to use.

2 Likes

@manuel, @dalto, @Echoa ,

You are just great!
I will make those changes and get back to you with the result.
Thank you!

2 Likes

Good luck! :sweat_smile:

1 Like

you got this, just some slight configuration issues is all. :+1:

2 Likes

Never before have I been happier to be greeted by a black TTY!

Thank you so much guys, you are wonderful!
I’ve got some connectivity issues to sort out. Hopefully I can manage on my own.

:purple_heart:

2 Likes

@dalto, @manuel, @Echoa

Sorted out the connectivity issue as well. Just have to decide now what to install from here. I think I’ll give it some rest and pick it up tomorrow.

Thanks again for your support and encouragement!

Have a beautiful weekend!

3 Likes