Grub is broken after first upgrade

I have install latest endeavouros 21_5 iso image in offline mode (auto partition + encrypt).
After logging into a freshly installed system, the first thing I tried to do was to upgrade it.
Everything was going well until it came to updating grub.
The last line in terminal was (unfortunately i don’t remember previous):

arch found fallback initrd image in boot

Then the system totally froze…
I waited more than 5 minutes and I had no choice but to hard reboot.
Now, grub throws an error:

error: you need to load the kernel first

It is my first experience with arch (previously, I used ubuntu, debian, centos).
I have a question. Is it normal in arch to ruin the entire system with the first upgrade? :slightly_smiling_face:
It’s somehow scary to use arch and upgrade it after this.

Is it possible to somehow update it without fear of losing everything? Do not offer to make a snapshot before each update, please. This is the first time I’ve experienced a total system crash in over 15 years during upgrade. Other Linux distributions also had troubles with updates sometimes, but never so serious.

When you forcibly reboot in the middle of a very large update like that, you are almost guaranteed to have a broken system.

The abnormal thing is that your system hard froze while running the post-transaction hooks.

That being said, it shouldn’t be too hard to fix. Boot off the ISO, arch-chroot in and then run pacman -Syu linux from the chroot.

Also, welcome to the forum!

1 Like

Yes, I expected the system to no longer boot after that. But the system was totally freezed (none key combinations worked, mouse did not moved).

That being said, it shouldn’t be too hard to fix. Boot off the ISO, arch-chroot in and then run pacman -Syu linux from the chroot.

Is it possible to do that while disk is encrypted?

This incident should be unusual and don’t let yourself be scared away. You’ve already earned your first merits on other distros, you’ll make it here.
Welcome to the forum :enos_flag: :enos:

Yes, you just need to decrypt the disk before creating the chroot.

Ok, i’m in live dvd now.
I had mount encrypted partition, chroot in it and do what you say (I write command mostly for me to future :slightly_smiling_face:):

cryptsetup luksOpen /dev/sda1 crypto
mount /dev/mapper/crypto /mnt
sudo arch-chroot /mnt
pacman -Syu linux

There are no errors. Rebooting.

Thank you! It’s working, you’re the best! Really so easy. :handshake:

1 Like

Welcome to the forum and Endeavour!

Just to be clear this is your first experience with Endeavour. While we are Arch based, we are not Arch. It can be a little confusing, but please know you are only using Arch if you install Arch in a manner that entitles you to help from their help forum or other help channels (following their install guide, or using their archinstall script ONLY).

If you have any more issues, please let us know. We’re a welcoming place and we can help you along if your goal is to use Arch, or just enjoy the ease of Endeavour.

1 Like

You should really mark @dalto’s post as the solution. You’ve pretty much copied what he told you and marked it as your own solution. I know dalto does not care, but it looks quite ungrateful, regardless…

Ok, you’re right

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.