Grub how to choose kernel in submenu

After I uncomment GRUB_DISABLE_SUBMENU=y, I no longer get all the kernel options for Arch linux, instead only a Arch linux entry. How can I go to submenu to choose which kernel to boot with in this case? or how can I set which kernel to boot with default?

Are you referring to a separate Archlinux installation, or do you mean your EnOS installation?
Or re-enable submenus to get them back… :person_shrugging: :thinking:

Its EOS, they changed the entry name from EOS to Arch in the latest grub update iirc

Set this:


You may have incorrectly merged some .pacnew file, or something similar.
The name of your native system in Grub menu is configured in /etc/default/grub with a variable:

GRUB_DISTRIBUTOR="Arch" # or whatever text you like

As for the original topic question, I would be surprised if grub has changed the behavior of the GRUB_DISABLE_SUBMENU option.
Until now, I thought the various kernel options were not hidden, rather included in one single menu.

Can you please clear this question of mine? Are all the kernels, except the first/main one, hidden?
Or was it maybe a communication problem?
Thanks in advance!

This can also be caused be removing grub and installing it again.

1 Like

Yes, all the kernels are hidden, including the main one, there is only a Arch Linux option, along with something called advanced option for arch linux.

I just update grub along with the system update, it says there is a pacnew so I just move the pacnew to the default grub file, and remove the previous grub file (to .bak).

you need to merge them as this pacnew is created in addition with new changes from package update if you replace the already installed one you will remove all changes done to your config by EndeavourOS or you… so procedure would be to diff both and add new config parts into your old config…

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.