Grub 2:2.06.r322.gd9b4638c5-1 won't boot and goes straight to the BIOS after update

What show:

test -d /sys/firmware/efi && echo UEFI || echo BIOS

lsblk -fs

cat /etc/fstab

?

[raccoon@den ~]$ test -d /sys/firmware/efi && echo UEFI || echo BIOS
BIOS
[raccoon@den ~]$ lsblk -fs
NAME FSTYPE FSVER LABEL UUID FSAVAIL FSUSE% MOUNTPOINTS
sda1 btrfs 76932b02-4584-4d33-a12c-7dbb02df6b04 438,7G 4% /var/log
│ /var/cache
│ /home
│ /
└─sda

sda2 swap 1 swap 71b32d9c-342e-4e6a-afda-61bb1ac4d205 [SWAP]
└─sda

sdb1 ntfs vault 686BA3D0527BB94B
└─sdb

[raccoon@den ~]$ cat /etc/fstab

/etc/fstab: static file system information.

Use ‘blkid’ to print the universally unique identifier for a device; this may

be used with UUID= as a more robust way to name devices that works even if

disks are added and removed. See fstab(5).

UUID=76932b02-4584-4d33-a12c-7dbb02df6b04 / btrfs subvol=/@,defaults,noatime,compress=zstd 0 0
UUID=76932b02-4584-4d33-a12c-7dbb02df6b04 /home btrfs subvol=/@home,defaults,noatime,compress=zstd 0 0
UUID=76932b02-4584-4d33-a12c-7dbb02df6b04 /var/cache btrfs subvol=/@cache,defaults,noatime,compress=zstd 0 0
UUID=76932b02-4584-4d33-a12c-7dbb02df6b04 /var/log btrfs subvol=/@log,defaults,noatime,compress=zstd 0 0
UUID=71b32d9c-342e-4e6a-afda-61bb1ac4d205 swap swap defaults 0 0
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0

Unrelated whining: Man using a laptop when used to a desktop feels clumsy as hell.

The command:

sudo grub-install --target=x86_64-efi –efi-directory=/boot/efi --bootloader-id=EndeavourOS-grub

is for UEFI boot mode. Your system boots on bios/mbr/legacy mode. That’s why:

If I have understood the recent Grub issue, only systems wit UEFI boot mode are affected.
So your’s should be fine.

At any rate, for reinstalling the bootloader in bios mode:

sudo grub-install --target=i386-pc /dev/sdX

Replace X with the letter of the device. In your case that would be a.

1 Like

Thank you very much for your help, I now realize it was a dumb question, I just got a bit paranoid with the issues that happened lately.

2 Likes

Thanks for making things clearer!

:v:

2 Likes

Done all but not when I try to boot I get this message
image

This usually means you need to manually set the correct EFI entry to boot from. Either by using efibootmgr or just going into your BIOS and picking the correct option in the boot section.

I, as many, got to bios after update the endeavourOS, and after hardship understanding I think I did manage go through the steps on the endeavour OS website. However it got me another issue when booting. Before I’m able to do anything, even before able to boot into a live USB I get to a black screen, the acer logo in middle and top right like a command line saying: “welcome to GRUB!

Error: symbol grub_debug_malloc’ not found. Entering rescue mode grub rescue>”

I’m kind of a noob having hard time understand at all these kind of things so kinda a miracle I didn’t just give up from start, but I spent time on the DE and have documents I don’t want to loose so… However I tried to search it, and I found I could write “set”, pressing enter I get the following: (providing image)
Skärmbild_2022-08-27_19-31-35

I assume that’s some information about my device but I don’t understand what this is or what has happened or what to do further, if this is fixable, please help me. Thank you so much in advance.
Skärmbild_2022-08-27_19-32-12

This usually means you need to manually set the correct EFI entry to boot from. Either by using efibootmgr or just going into your BIOS and picking the correct option in the boot section.

This should really go into the warning (heads-up) thread, @moderators !
@dalto 's fingers must be dripping blood by now… @sradjoker

3 Likes

Indeed, following the procedure I ended-up with 2 entries:

EndeavourOS-grub (new one)
and
EndeavourOS (the old one)

Make sure you select the right one in the boot menu.

1 Like

Thank you so much for guide @Lugh and patience @dalto

The guide from @Lugh worked for me and everything is fine now.

Love you! :heart:

2 Likes

Great ! Happy that I could help ! @dalto is the hero here !

1 Like

Done. @sradjoker wrote something earlier. I merged it in.

1 Like

…is here, please ALL, follow it exactly:
https://forum.endeavouros.com/t/the-latest-grub-package-update-needs-some-manual-intervention/30689/4

There shouldn’t be any more questions left, hardly, thereafter!

1 Like

I would add an example to this sentence “where xxx is the boot entry corresponding to EndeavourOS-grub” (e.g. efibootmgr -o 0002,0003,0001) because newbies could fail.

3 Likes

@dalto , @sradjoker !

Done.

2 Likes

A post was split to a new topic: Booting from vmlinuz-linux image file with btrfs in rEFInd

To be repeated…