Grub 2:2.06.r322.gd9b4638c5-1 won't boot and goes straight to the BIOS after update

Search discovery, there should be instructions there

I followed the link in Discovery but didn’t get too far but Dalto’s link above seems to be a good reference which I will try now

I edited my post and added them in.

This whole conversation started with him trying to follow those instructions.

thanks bunch @dalto and @Lugh. The above steps worked :slight_smile:

image

2 Likes

After an update that require system restart, my system not boot anymore, im redirected to BIOS settings while the boot, no text is shown on screen. I am on live cd with Endeavour os now, can i do anything to solve this?

Yes. Take a look at the instructions here:

I mount the partition and enter in chroot with exit, but i see this error when try “grub-install”:

Installing for x86_64-efi platform.
grub-install: error: cannot find EFI directory.

Can we see the output of findmnt --real

TARGET SOURCE    FSTYPE OPTIONS
/      /dev/sda2 ext4   rw,relatime

It looks like you didn’t mount your EFI partition.

yes, sorry, i do it and try again. now this output for findmnt --real is:

TARGET      SOURCE    FSTYPE OPTIONS
/           /dev/sda2 ext4   rw,relatime
└─/boot/efi /dev/sda2 ext4   rw,relatime

and grub-install now return:

Installing for x86_64-efi platform.
grub-install: error: /boot/efi doesn't look like an EFI partition.

You mounted the same partition twice. /dev/sda2 can’t be both your EFI partition and your / partition.

1 Like

lol, I didn’t understand that I should mount my efi partition, thanks, it worked.

1 Like

Hi!

After having followed the suggested recovery steps (The latest grub package update needs some manual intervention) I get an error when GRUB is started:

error: symbol `grub_debug_malloc` not found

and GRUB enters rescue mode.

No errors have happened / have been logged while doing the grub-install.

Can anyone please help me with that?

In this case, you should go into your BIOS and select the new entry to boot off of.

This is also mentioned in the post.

The problem is people are not reading the pinned post’s. They read through these posts and and there is so much information and it is all over the place because not every issue is the same as they may have.

4 Likes

Those who can read are at a clear advantage. Problems seem to happen, when under stress…

2 Likes

Yes i understand reading and understanding do not always go hand in hand. :wink:

4 Likes

Why haven’t I realized before that you have a good sense of humor?

Now with the update, both my computers (laptop & desktop) spend more time in the pre-grub screen (the one that says your motherboard’s company name).
(Yes idk what’s its name :skull:)