Grub 2:2.06.r322.gd9b4638c5-1 won't boot and goes straight to the BIOS after update

While you can do this, it is not the recommended solution here.

1 Like

There are instructions on a separate pinned post for your case too!!

2 Likes

it happened to me and I’m not using os-prober.
I use F8 to select from the BIOS boot menu when I want to boot to other OS that is not EnOS.

1 Like

thank you, this worked. I never did a grub repair on arch before. I had my /boot partition separately, also had to mount that too.

1 Like

Never mind.

I just did a fresh online installation on this computer (which automatically updated it) and the computer works. Fortunately Documents, etc., were backed up onto hard drives.

Lawrence

1 Like

Regenate grub or reinstall

Grub-mkconfig -o /boot/grub/grub.cfg

Can do

Is the buggy update still available or is it safe to update now?

You can track the package here if you like: https://archlinux.org/packages/core/x86_64/grub/

Quick answer, no the grub package has not yet been updated/fixed upstream, hence the need for pinned posts here to help users.

So to summarize:

  1. Update - don’t reboot!

  2. Re-install grub:

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS
  1. Update grub:
sudo grub-mkconfig -o /boot/grub/grub.cfg
  1. Oh yeh, reboot :smiley: :smiley:
    :crossed_fingers:
    Correct??
3 Likes

Correct :+1:

It’s also explained here too in a recent pinned post:

1 Like

@adjagu @dalto Thanks for that posting, much appreciated!

sudo arch-chroot /mnt

I see what i was doing wrong, that command helped. :crazy_face: :flushed: :grimacing: :rofl:

:smiley: was to busy reading this (I was not affected either).

Well, in the past I NEVER manually installed the updated grub. Running grub-mkconfig alone lead to the new grub version being used at the next boot, so I saw no reason to reinstall grub with every update.
And: grub-mkconfig is run automatically with a hook.

1 Like

I don’t expect a fix that fast, but why the hell hasn’t the update been withdrawn? It’s 10 hours since the first reports came in here.

oh yes… it is always your own fault and indeed if it is caused by os-prober usage… its disabled per default on arch so not an issue with the defaults only if you change it…

I will try reproduce os-prober as the reason of the issue…

4 Likes

That didn’t work for me.
I came to a grub rescue instead.

I think I’ll ignore it until package is fixed

EDIT: I do use grub-btrfs added as well so might be why

could be there will be no fix for this…

I tried this but I got

liveuser@eos-2022.06.23 ~]$ sudo grub-mkconfig -o /boot/grub/grub.cfg
/usr/bin/grub-probe: error: failed to get canonical path of `airootfs'.
[liveuser@eos-2022.06.23 ~]$ 

and

liveuser@eos-2022.06.23 ~]$ sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS-grub
Installing for x86_64-efi platform.
grub-install: error: failed to get canonical path of `/boot/efi'.
[liveuser@eos-2022.06.23 ~]$