Grub 2:2.06.r322.gd9b4638c5-1 won't boot and goes straight to the BIOS after update

I had to take the disk out of the computer and to reformat it using a cable and another computer.
Used GPARTED and it appears to work. The bad news is that by doing taht I’ve lost a bunch of files…
The big question is what went wrong after the update so that I never got it boot in live media…
If this could help - it is a LENOVO IDEAPAD with RYZEN 7 CPU.

We are by extension Arch, so we’d really just be busting on ourselves :wink:

(not being serious btw, only joking of course!)

The community is much friendlier than vanilla arch community.
I never liked vanilla much anyway, I prefer chocolate.

1 Like

That’s the main reason I’m here instead of there.

2:2.06.r322.gd9b4638c5-4

Brought back the colored (previous) grub menu

Do not know if it was necessary, but since these instructions were shown after update, I used them:
sudo grub-install…
sudo grub-mkconfig -o /boot/grub/grub.cfg

1 Like

Hello community
I run today pacman syu and after can’t boot on system.
I checked this topic here: The latest grub package update needs some manual intervention and did instructions but at the stage where have to run grub-install says: /boot/efi doesn’t look like an EFI partition
20220904_213051

Is your system uefi?

[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
…will tell you either way.

1 Like

User should know this. :wink:

You don’t know what they don’t know. :wink:

I know some things. :innocent:

Edit: But you are right. I don’t know a lot of things! :laughing:

Maybe, but Dalto got this info out pretty quick. Gotta give credit there…

1 Like

An OT reminder sometimes seems neccesary, again, and again…

So, who’s going to open up a new thread in PUB for such chit-chat about things that should or shouldn’t be, surrounding this grub-issue or related matters, since it seems to be always tempting to many (including myself), to engage in?

(I just did it.)

try

sudo LANG=C grub-mkconfig -o /boot/grub/grub.cfg

? idk :slight_smile:

https://bugzilla.redhat.com/show_bug.cgi?id=817187#c42

way old… :slight_smile:

All sorts of hiccups showing up from the change in Grub…

It would be a possible solution, but we have experienced such mistake/error during the Topic’s grub issue. The user has to verify that is booting the correct UEFI entry and not the old one (using the UEFI/BIOS quick boot menu, during boot).

1 Like

ahh… ok :slight_smile:

edit: now the bells rings :stuck_out_tongue:

1 Like

[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
UEFI

its uefi

but same error:

sudo grub-install
Installing for x86_64-efi platform.
grub-install: error: /boot/efi doesn't look like an EFI partition.

That seems to show mounting erros. I’m out of this issue, as I don’t have a single UEFI Linux system running myself (only Legacy Bios).

Someone will soon come to your rescue here, I’m confident.

1 Like

Can you set the boot-order from your UEFI bios?