Graphics issue on some applications

Hello, some applications don’t render properly. I tried reinstalling them but had no luck. System is up to date. The affected applications are: bottles, pamac, vscode and probably more. Here is the output of inxi -Fxxxz:

  Kernel: 6.4.8-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    Desktop: i3 v: 4.22 info: polybar vt: 7 dm: LightDM v: 1.32.0
    Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: LENOVO product: 20KN001NGE v: ThinkPad E480
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20KN001NGE v: SDK0J40697 WIN
    serial: <superuser required> UEFI: LENOVO v: R0PET72W (1.49 )
    date: 01/30/2023
  ID-1: BAT0 charge: 24.9 Wh (66.0%) condition: 37.7/45.3 Wh (83.2%)
    power: 29.5 W volts: 12.3 min: 11.1 model: SMP 01AV446 type: Li-poly
    serial: <filter> status: charging cycles: 693
  Info: quad core model: Intel Core i7-8550U bits: 64 type: MT MCP
    smt: enabled arch: Coffee Lake rev: A cache: L1: 256 KiB L2: 1024 KiB
    L3: 8 MiB
  Speed (MHz): avg: 1512 high: 2000 min/max: 400/4000 cores: 1: 2000 2: 2000
    3: 2000 4: 700 5: 703 6: 2000 7: 700 8: 2000 bogomips: 32012
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel
    arch: Gen-9.5 ports: active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2
    bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300
  Device-2: AMD Lexa PRO [Radeon 540/540X/550/550X / RX 540X/550/550X]
    vendor: Lenovo driver: amdgpu v: kernel arch: GCN-4 pcie: speed: 2.5 GT/s
    lanes: 4 bus-ID: 02:00.0 chip-ID: 1002:699f class-ID: 0380 temp: 56.0 C
  Device-3: Bison SunplusIT Integrated Camera driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 1-6:3 chip-ID: 5986:2113
    class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: intel dri: i965
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP1 model: AU Optronics 0x423d res: 1920x1080
    hz: 60 dpi: 157 size: 310x170mm (12.2x6.69") diag: 354mm (13.9")
    modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 23.1.5 renderer: AMD Radeon 500 Series (polaris12
    LLVM 15.0.7 DRM 3.52 6.4.8-arch1-1) direct-render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:9d71
    class-ID: 0403
  API: ALSA v: k6.4.8-arch1-1 status: kernel-api
  Server-1: PipeWire v: 0.3.77 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1
    port: c000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie:
    speed: 5 GT/s lanes: 1 bus-ID: 05:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 1-5:5 chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 471.36 GiB used: 127.88 GiB (27.1%)
  ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 238.47 GiB
    speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter> fw-rev: 5111AALA
    temp: 48.9 C scheme: GPT
  ID-2: /dev/sda vendor: Crucial model: CT250MX500SSD1 size: 232.89 GiB
    speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 023 scheme: GPT
  ID-1: / size: 231.9 GiB used: 127.77 GiB (55.1%) fs: btrfs dev: /dev/sda2
  ID-2: /home size: 231.9 GiB used: 127.77 GiB (55.1%) fs: btrfs
    dev: /dev/sda2
  ID-3: /var/log size: 231.9 GiB used: 127.77 GiB (55.1%) fs: btrfs
    dev: /dev/sda2
  Alert: No swap data was found.
  System Temperatures: cpu: 58.0 C pch: 57.5 C mobo: N/A gpu: amdgpu
    temp: 56.0 C
  Fan Speeds (RPM): N/A
  Processes: 265 Uptime: 10m wakeups: 2 Memory: total: 16 GiB note: est.
  available: 15.39 GiB used: 2.12 GiB (13.8%) Init: systemd v: 254
  default: graphical Compilers: gcc: 13.2.1 Packages: pm: pacman pkgs: 1160
  Shell: fish v: 3.6.1 running-in: xfce4-terminal inxi: 3.3.28

and here is a screenshot of said behavior:

I see you’re rendering with amdgpu.

API: OpenGL v: 4.6 Mesa 23.1.5 renderer: AMD Radeon 500 Series (polaris12
    LLVM 15.0.7 DRM 3.52 6.4.8-arch1-1) direct-render: Yes

I wonder if you were to set tear free rendering in:


Section "OutputClass"
        Identifier "amdgpu-pro"
        MatchDriver "amdgpu"
        Driver "amdgpu"
        Option "TearFree" "on"

Hm, good you spotted that! I did not intend to use that gpu, I would very much prefer to use the intel graphics :smile: do you happen to know how I can achieve that? I do not have a /etc/X11/xorg.conf.d/20-amdgpu.conf file. But I do have this (/etc/X11/xorg.conf.d/20-intel.conf):

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "Backlight"  "intel_backlight"

This is a lenovo laptop with Intel Cpu that has onboard graphics with a dedicated Radeon Gpu? Check your UEFI Bios settings as you may be able to set it to use integrated graphics.

Edit: If there are no settings in UEFI Bios to set integrated, hybrid or dedicated you may have to use a method to switch such as optimus-manager or other.

I got it solved with blacklisting the amdgpu driver in /etc/modprobe.d/blacklist.conf and running

sudo dracut -f

followed by a reboot. Thanks!

Note: I chose to disable the AMD Lexa PRO [Radeon 540/540X/550/550X / RX 540X/550/550X] since it has no real perfomance benefit over the integrated graphics and hurts the battery on my laptop.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.